Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Switched Servers - Importing Products
 
TJNevis
Member
 
Total Posts:  40
Joined:  2008-03-16
 

Hello,

I had to switch servers, mostly in hopes that the store would go a little faster.  I saved an sql file from phpmyadmin and I had to go through and run sql commands for INSERT INTO to each of the databases in magento_cart, the main database.  I have my menu, prices, pictures, descriptions, and the rest of the product information in.  But on the home page, the links don’t work. 

http://919imports.net/

This is an example of a link on the homepage (that magento creates)
http://919imports.net/catalog/category/view/s/festivity/id/93/

It shows an error when you click on it, but if you insert INDEX.PHP, it will work.

http://919imports.net/index.php/catalog/category/view/s/festivity/id/93/

But, the images don’t show up for the products on these pages.  What went wrong?  (so I can learn in the future, I don’t know too much about MYSQL) Also, how can I fix this?

Thanks

-TJ

 
Magento Community Magento Community
Magento Community
Magento Community
 
TJNevis
Member
 
Total Posts:  40
Joined:  2008-03-16
 

Looking at why the images don’t show up when you get to the section page that shows the products, I guess I forgot to download the skin folder, I only downloaded the media folder when I switched servers.  So i guess I will have to upload those again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mageho
Sr. Member
 
Avatar
Total Posts:  291
Joined:  2008-03-24
France, Paris
 

mod_rewrite (Apache) is activated ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
TJNevis
Member
 
Total Posts:  40
Joined:  2008-03-16
 

I checked it off when I was installing the store.  How do I double check?  Is it an .htaccess rewrite problem?

 
Magento Community Magento Community
Magento Community
Magento Community
 
TJNevis
Member
 
Total Posts:  40
Joined:  2008-03-16
 

OK.  It was the .htaccess.  I had to unhash the rewritebase to show “RewriteBase /”

All is good now!!

Now it just seems like I wasted a whole day messing around with the sql when that was all I had to do.  At least I learned something and I figured out what NOT to do with the SQL as well as Magento already has a built in product export feature, but I’m not sure it exports the categories and links (upsells/relateds/cross sells).

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top