Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Error after deleting store
 
ODB
Sr. Member
 
Avatar
Total Posts:  142
Joined:  2008-02-06
London
 

Just deleted a couple stores I think are causing me some problems and I get this error at the top of the page above the header. I’m usually pretty good at deciphering error messages but I can’t make head nor tail of this one:

Recoverable ErrorArgument 1 passed to Mage_Core_Model_Store::setGroup() must be an instance of Mage_Core_Model_Store_Groupnull givencalled in /var/www/html/app/code/core/Mage/Core/Model/App.php on line 342 and defined in /var/www/html/app/code/core/Mage/Core/Model/Store.php on line 585
[0] in Mage_Core_Model_Store
->setGroup(NULLin /var/www/html/app/code/core/Mage/Core/Model/App.php on line 342
[1] in Mage_Core_Model_App
->_initStores() in /var/www/html/app/code/core/Mage/Core/Model/App.php on line 208
[2] in Mage_Core_Model_App
->init("default""store"NULLin /var/www/html/app/Mage.php on line 402
[3] in Mage
::app("default""store"NULLin /var/www/html/app/Mage.php on line 422
[4] in Mage
::run("default"in /var/www/html/index.php on line 40

Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top