Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Copying database does not append SID to multiple store switcher
 
oakRunk
Sr. Member
 
Total Posts:  117
Joined:  2008-09-15
 

I copied my database and installed a new copy of magento. This will be used for “testing” purposes such as new extensions, upgrades, etc.

I changed the base URL everywhere (except where obviously did not need to be changed). Example: mystore.com/realstore => mystore.com/demo.

However, now when I use the store switcher, no SIDs are generated. It just goes from store1.com to store2.com but no SID = no cart sharing, no good.

Anyone else have this problem, or better yet a solution?

Yes, cache and cookies are cleared from browser, admin, and directory.

Actually, I had this problem before but I do not remember the solution!!!!

Thanks in advance!

 
Magento Community Magento Community
Magento Community
Magento Community
 
oakRunk
Sr. Member
 
Total Posts:  117
Joined:  2008-09-15
 

anyone experience this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
laumann
Jr. Member
 
Total Posts:  10
Joined:  2010-04-29
 

i have the same problem!

Sid will not generate when switching between stores

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top