Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Installation on VMware server 1.0.5 [ Ubuntu server 7.10 LAMP ] WINXP
 
Icefire
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2007-11-02
Netherlands, the
 

Hi,

I managed to almost successfully install magento 1.0 on a VMware server with Ubuntu server 7.10 LAMP.
I used this tutorial http://www.magentocommerce.com/boards/viewthread/2505/, its a bit out of date but it work for 80%.

Magento installed with success and completion, but i still have one major problem.
When i go to the frontend its show the mainpage perfectly. but when i click a link (any link eg; log in, my account, contact us) it says the page can not be found.

the adminpanel however works like a charm and product image upload works to.
If someone can give me a bit of help that would be great.

My network information;

Gateway 192.168.1.1
Computer ip that is running VMware server 192.168.1.8
VMware server ip 192.168.142.128 [ Using NAT ]

In Ubuntu i did not set a static ip, i cannot get it to work by changing (/etc/network/interfaces)

Sincerely,

ICEFIRE

 
Magento Community Magento Community
Magento Community
Magento Community
 
Simon King
Member
 
Avatar
Total Posts:  46
Joined:  2008-01-10
 

It sounds like a URL rewriting issue. To verify this turn rewrite off and see if the front end works. To do this go to System -> Configuration -> General -> Web and set ‘Use Web Server Rewrites’ to No.

If that solves your problem, you probably still want to use rewrites. The ‘proper’ debian/ubuntu way of enabling apache modules is to use the a2enmod script, e.g. sudo a2enmod rewrite (sudo a2dismod rewrite to disable it)

You’ll then need to reload apache using:

sudo /etc/init.d/apache2 force-reload

If that still doesn’t work, make sure you have an entry in your httpd configuration that looks like:

<Directory /path/to/magento>
AllowOverride All
</Directory>

to enable .htaccess files

Simon

 
Magento Community Magento Community
Magento Community
Magento Community
 
Icefire
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2007-11-02
Netherlands, the
 

I think indeed that wil help me, but no i did something else to correct it and i did something wrong.

I could not get into the magento connect section in the admin panel because of an permissions error.
So it try’d setting chmod permissions for /var/www/magento etc. only now i cannot get in the front and backend anymore, it gives me this error;

Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0
Fatal error: Unknown: Failed opening required ‘/var/www/magento/index.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in Unknown on line 0

so i cannot get in to admin panel to test your solution.

Does someone know how to reset those permissions to make it work again.
I re-entered the steps from the tutorial, but that did not help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Simon King
Member
 
Avatar
Total Posts:  46
Joined:  2008-01-10
 

Sure.

You’re running ubuntu, so chances are your webserver is running as the www-data user. It’s probably best to have the files owned by you, but writeable and readable by www-data:

sudo chown -R your_user_name:www-data /var/www/magento

You then need to make sure that all directories are 775:

sudo find /var/www/magento -type d xargs chmod 775

And all files are group and owner readwrite:

sudo find /var/www/magento -type f xargs chmod o+w,o+r,g+w,g+r

and best just making sure the magento directory itself is right:

sudo chown 775 /var/www/magento
 
Magento Community Magento Community
Magento Community
Magento Community
 
Icefire
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2007-11-02
Netherlands, the
 

Thank you, you guys helped me alot. smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top