Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Help me please !!! Warning: fopen() has been disabled for security reasons in /home/namelogin/public_html/lib/Varien/File/Csv.php on line 85
 
Kingonepiece
Jr. Member
 
Total Posts:  5
Joined:  2008-04-05
 

Warning: fopen() has been disabled for security reasons in /home/namelogin/public_html/lib/Varien/File/Csv.php on line 85[0] in fopen("/home/namelogin/public_html/app/locale/en_US/Mage_Core.csv", “r") in /home/namelogin/public_html/lib/Varien/File/Csv.php on line 85[1] in Varien_File_Csv->getData("/home/namelogin/public_html/app/locale/en_US/Mage_Core.csv") in /home/namelogin/public_html/lib/Varien/File/Csv.php on line 104[2] in Varien_File_Csv->getDataPairs("/home/namelogin/public_html/app/locale/en_US/Mage_Core.csv") in /home/namelogin/public_html/app/code/core/Mage/Core/Model/Translate.php on line 284[3] in Mage_Core_Model_Translate->_getFileData("/home/namelogin/public_html/app/locale/en_US/Mage_Core.csv") in /home/namelogin/public_html/app/code/core/Mage/Core/Model/Translate.php on line 190[4] in Mage_Core_Model_Translate->_loadModuleTranslation("Mage_Core", Array[1]) in /home/namelogin/public_html/app/code/core/Mage/Core/Model/Translate.php on line 110[5] in Mage_Core_Model_Translate->init("adminhtml") in /home/namelogin/public_html/app/code/core/Mage/Core/Model/App/Area.php on line 138[6] in Mage_Core_Model_App_Area->_initTranslate() in /home/namelogin/public_html/app/code/core/Mage/Core/Model/App/Area.php on line 113[7] in Mage_Core_Model_App_Area->_loadPart("translate") in /home/namelogin/public_html/app/code/core/Mage/Core/Model/App/Area.php on line 85[8] in Mage_Core_Model_App_Area->load() in /home/namelogin/public_html/app/code/core/Mage/Core/Model/App.php on line 464[9] in Mage_Core_Model_App->loadArea("adminhtml") in /home/namelogin/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php on line 368[10] in Mage_Core_Controller_Varien_Action->preDispatch() in /home/namelogin/public_html/app/code/core/Mage/Adminhtml/Controller/Action.php on line 108[11] in Mage_Adminhtml_Controller_Action->preDispatch() in /home/namelogin/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php on line 334[12] in Mage_Core_Controller_Varien_Action->dispatch("index") in /home/namelogin/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Admin.php on line 141[13] in Mage_Core_Controller_Varien_Router_Admin->match(Mage_Core_Controller_Request_Http) in /home/namelogin/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php on line 147[14] in Mage_Core_Controller_Varien_Front->dispatch() in /home/namelogin/public_html/app/Mage.php on line 424[15] in Mage::run("default") in /home/namelogin/public_html/index.php on line 40

website : http://www.jerseysoccershop.com/admin

how do i do ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Simon King
Member
 
Avatar
Total Posts:  46
Joined:  2008-01-10
 

It sounds like your php.ini configuration settings are preventing local files being opened. From http://uk.php.net/fopen :

If PHP has decided that filename specifies a local file, then it will try to open a stream on that file. The file must be accessible to PHP, so you need to ensure that the file access permissions allow this access. If you have enabled safe mode, or open_basedir further restrictions may apply.

If PHP has decided that filename specifies a registered protocol, and that protocol is registered as a network URL, PHP will check to make sure that allow_url_fopen is enabled. If it is switched off, PHP will emit a warning and the fopen call will fail.

Since the file being opened is not on the network, you can rule out allow_url_fopen. So things to check are firstly that if you have open_basedir set that it set to allow files in your magento directory to be opened - I’d suggest using /home/onepiece/public_html/

If that doesn’t work, and safe_mode is on, try turning it off. It’s probably on for a reason so if this does work it’s probably worth looking at how you can use magento with safe_mode on.

Simon

 
Magento Community Magento Community
Magento Community
Magento Community
 
Kingonepiece
Jr. Member
 
Total Posts:  5
Joined:  2008-04-05
 

Thank you very much . just set open_basedir and Ok

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top