Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 3
IIS Windows Servers, PHP, Zend, Magento stuff
 
kpmt-technician
Jr. Member
 
Total Posts:  8
Joined:  2008-10-13
 

I have a Window 2003 Standerd OS running on a Virtual Server that is running IIS 6, PHP 5.2.6 and MySQL 5.0.67.  I am unable to get the Magento website to install correctly.  I have installed the Isapi Rewrite 3 and added the following:

# Helicon ISAPI_Rewrite configuration file
# Version 3.1.0.56

RewriteEngine on
#RewriteBase /magento/
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule .* index.php [L]

My file permission are IUSER_ (full control over the install directory).
I have created my MYSQL database and User, plus imported sample data.

But still have NOT made it past the downloader.....
The button labeled, “Contiue Magento Installation.” goes to > http://MYURL/Magento and then “Internet Explorer cannot display the webpage.” Acts as if the default content page is not being displayed.  But when I append index.php I get the same result.  Then I have verified that the page is in the directory, it is.  Really confused on where to go from here.  Please help....

Robert FIdler, Springfield, Missouri

 
Magento Community Magento Community
Magento Community
Magento Community
 
TSCAD-FX
Jr. Member
 
Total Posts:  10
Joined:  2008-10-06
Sacramento CA
 

Robert,

It sounds as if the ISAPI rewrite isn’t working correctly.  Like I’ve mentioned, I’ve got Magento to install on a couple of MS servers and it works great.  I’ve been using standard server ‘08 with IIS7, but I don’t think that it should matter. 

I would restart the IIS service if you haven’t already and try again.  I would also make sure that in the properties dialog of the web site that the isapi module is listed.  Each time I did the install I placed all of the files in wwwroot/ without the magento directory.

Also, in your .htaccess file make sure that the below is shown otherwise it will try to place a leading slash after index.php

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on
RewriteRule .*/index\.php/$ index.php

If you can’t get it to work and you really want help, I’d be more than happy to do a webex session with you or a phone call and assist you with the install.  Let me know how it goes.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kpmt-technician
Jr. Member
 
Total Posts:  8
Joined:  2008-10-13
 

Thank you very much for the offer of a webex session or a phone call in assisting me with the installation.  Due to the my clients data stored within my network I would be breaching our confidentiality contracts but thank you for the offer.

I believe the ISAPI rewrite is installed correctly but I agree that it seems to be having issues.  I have pasted my config file and .htaccess files below, also my website live in the root directory, meaning I also removed the /megento/ directory.

##################BEGIN OF Helicon ISAPI_Rewrite configuration file ###############################
RewriteEngine on
#RewriteBase /magento/
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule .* index.php [L]
##################END OF Helicon ISAPI_Rewrite configuration file ###############################

##################BEGIN OF root .htaccess file ###############################
############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

# Action php5-cgi /cgi-bin/php5-cgi
# AddHandler php5-cgi .php

############################################
## GoDaddy specific options

# Options -MultiViews

## you might also need to add this line to php.ini
## cgi.fix_pathinfo = 1
## if it still doesn’t work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

# php_value memory_limit 64M
php_value memory_limit 128M
php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter
#SetOutputFilter DEFLATE

# Netscape 4.x has some problems…
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
# Don’t compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don’t deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault “access plus 1 year”

</IfModule>

############################################
## By default allow all access

Order allow,deny
Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none
##################END OF root .htaccess file ###############################

thanks again for all your help in this matter.

 
Magento Community Magento Community
Magento Community
Magento Community
 
TSCAD-FX
Jr. Member
 
Total Posts:  10
Joined:  2008-10-06
Sacramento CA
 

No problem with the support issue.  I completely understand.  There’s times that I get frustrated with my Cisco equipment and the command line interface not working correctly.  I love it when Cisco just pops in and shows me what’s wrong!  Anyhow, getting back to your issue.

In the httpd.conf change:

#RewriteBase /magento/
to
#RewriteBase /

In the .htaccess file change:
############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################

to

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on
RewriteRule .*/index\.php/$ index.php

############################################
## you can put here your magento root folder
## path relative to web root

RewriteBase /index.php

############################################

Try it again with these settings.  Also, don’t use http://yourdomain/install.php ... use http://yourdomain/index.php

Additionally, be sure that your php.ini file is configured correctly.  I’ll attach a copy of mine so that you can compare the two.

Good luck!

File Attachments
php.zip  (File Size: 17KB - Downloads: 107)
 
Magento Community Magento Community
Magento Community
Magento Community
 
kpmt-technician
Jr. Member
 
Total Posts:  8
Joined:  2008-10-13
 

Applied the above and still am getting the same results.  I have compared php.ini file, other then specific paths, they are identical.  I have attached my .htaccess and httpd.conf files after making the alterations you’d suggested.  Could you please verify that I make the corrections correctly.  New bee, with .htaccess and httpd.conf.

File Attachments
htaccess_httpd.zip  (File Size: 3KB - Downloads: 122)
 
Magento Community Magento Community
Magento Community
Magento Community
 
TSCAD-FX
Jr. Member
 
Total Posts:  10
Joined:  2008-10-06
Sacramento CA
 

I’ve reviewed the file that you sent and it looks good.  Lets go back to basics here, because like I said, I’ve installed Magento successfully on windows server ‘08 systems a number of times.  I actually provide hosting for magento on my IIS7 servers.

Have you tried creating a php info file and testing the install of php?
Are you sure that php is enabled in the IIS handler mappings for the site which contains the Magento files?
Look at the attached screen shot and make sure that at least the php is configured as shown.

Let me know if any of this information helps.  I would start at step one and look at everything again.  Because IIS requires extensive setup for Magento it’s hard to tell what the problem is.  Another suggestion would be to enable detailed error reporting (at least until you have it installed).  Therefore, if the page returns an error it is displayed in detail.

Image Attachments
iis7.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
kpmt-technician
Jr. Member
 
Total Posts:  8
Joined:  2008-10-13
 

Have you tried creating a php info file and testing the install of php?
>> I have a number of Joomla websites running on this server.
>> I have created a phpInfo() page within this working directory and tested php from it, all is well with php.

Are you sure that php is enabled in the IIS handler mappings for the site which contains the Magento files?
>> NOT sure, I have PHP handled correctly.  Are there other file types needed?

I am looking a starting from scratch on another box to check my server configuration.

Thanks again, I’ll keep the thread posted.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kpmt-technician
Jr. Member
 
Total Posts:  8
Joined:  2008-10-13
 

Partial Solution to Installation issues:
1.  Installed the full version of ISAPI Rewrite 3.

2.  From the command line ran the following:
c:\> c:\program files\php5\php.exe -f “c:\mywebsite_folder\install.php”—--license_agreement_accepted yes --locale en_US --timezone “America/Los_Angeles” --default_currency USD --db_host localhost --db_name magento_database --db_user magento_user --db_pass 123123 --db_prefix magento_ --url “http://magento.example.com/” --use_rewrites yes --use_secure yes --secure_base_url “https://magento.example.com/” --use_secure_admin yes --admin_lastname Owner --admin_firstname Store --admin_email “admin@example.com” --admin_username admin --admin_password 123123 --encryption_key “Encryption Key”

Now, I am able to view the home page, ie http://MYSITE.com/index.php, but when I click on anything like the “My Account” link I get “The page cannot be found” and the url is http://MYSITE.com/customer/account/?SID=CblP7OpduTgfNFw4dWkDH8cIyFvtlJntUW3bZCfK7jM&#x3D;.

Any Suggestions? 

I am creating a new instance of Magenta under my personal URL on the same server so you can view my results.

Thanks again for all your help in this matter.

Robert Fidler
Springfield, Missouri.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kpmt-technician
Jr. Member
 
Total Posts:  8
Joined:  2008-10-13
 

I have testing enviorment setup:  http://magento.robertfidler.com/

I am getting the same results as before.  I have know idea on how to access the admin panel or any other feature of the website.

please help....

 
Magento Community Magento Community
Magento Community
Magento Community
 
kpmt-technician
Jr. Member
 
Total Posts:  8
Joined:  2008-10-13
 

In my chois of uninstalling and re-installing stuff I forgot to edit the Helicon ISAPI_Rewrite configuration file:
RewriteRule .* index.php [L] >> RewriteRule .*/index\.php/$ index.php

Once I edited that and restarted IIS, all is well now.  I am currently working up a tutorial that walks though the complete install and I will post the link shortly.

THANK YOU for all your help!!!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
TSCAD-FX
Jr. Member
 
Total Posts:  10
Joined:  2008-10-06
Sacramento CA
 

Robert,

So I gather that you aren’t having any more issues?  All of those posts, you kinda lost me!  =)

Just to test things out go into the Admin panel and attempt to use Magento Connect.  Let me know if it works.  If it doesn’t I have a fix for that.  For some reason I’ve never been able to get it working on IIS without modifying a file.

I went to the site: http://magento.robertfidler.com/ and it is up and running!  I pleased to see that there’s another successful install of Magento on IIS and it appears to be much faster than other OS’s. 

Good Luck as always and keep me informed!

 
Magento Community Magento Community
Magento Community
Magento Community
 
atomicgroove
Jr. Member
 
Total Posts:  2
Joined:  2008-11-14
 

Robert,
if your working on a tutorial for installation on a windows server I would like to see it. I’m also having problems with the install.

 
Magento Community Magento Community
Magento Community
Magento Community
 
atomicgroove
Jr. Member
 
Total Posts:  2
Joined:  2008-11-14
 

bump grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
camulatz
Jr. Member
 
Total Posts:  7
Joined:  2008-12-13
 
TSCAD-FX - 15 October 2008 12:44 PM

Robert,

So I gather that you aren’t having any more issues?  All of those posts, you kinda lost me!  =)

Just to test things out go into the Admin panel and attempt to use Magento Connect.  Let me know if it works.  If it doesn’t I have a fix for that.  For some reason I’ve never been able to get it working on IIS without modifying a file.

I went to the site: http://magento.robertfidler.com/ and it is up and running!  I pleased to see that there’s another successful install of Magento on IIS and it appears to be much faster than other OS’s. 

Good Luck as always and keep me informed!

Hi TSCAD-FX,

I’m in the same situation, Magento Connect does not work at all.

Can you post the fix ?

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kralc
Jr. Member
 
Total Posts:  1
Joined:  2008-12-18
 

I’m trying to do the same thing. I’ve followed the instructions in this thread and I’m getting a “redirect loop” error when pointing to mysite.com/index.php

Please help

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 3