Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Attribute already exists
 
gento
Jr. Member
 
Total Posts:  16
Joined:  2007-09-30
 

When I use the “my cart” link on the idex page i get a bunch of these error messages.

I am on 1.0 and Lynux. Maybe I caused this issue by moving my entire installation from the magento folder upwards to root?

Thanks for help!

Warning: SimpleXMLElement::addAttribute() [function.SimpleXMLElement-addAttribute]: Attribute already exists in /var/www/vhosts/wm.com/httpdocs/app/code/core/Mage/Core/Model/Layout.php on line 156
[0] in SimpleXMLElement->addAttribute("ignore", “1") in /var/www/vhosts/wm.com/httpdocs/app/code/core/Mage/Core/Model/Layout.php on line 156
[1] in Mage_Core_Model_Layout->generateXml() in /var/www/vhosts/wm.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Action.php on line 261
[2] in Mage_Core_Controller_Varien_Action->generateLayoutXml() in /var/www/vhosts/wm.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Action.php on line 209
[3] in Mage_Core_Controller_Varien_Action->loadLayout() in /var/www/vhosts/wm.com/httpdocs/app/code/core/Mage/Checkout/controllers/CartController.php on line 81
[4] in Mage_Checkout_CartController->indexAction() in /var/www/vhosts/wm.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Action.php on line 341
[5] in Mage_Core_Controller_Varien_Action->dispatch("index") in /var/www/vhosts/wm.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php on line 150
[6] in Mage_Core_Controller_Varien_Router_Standard->match(Mage_Core_Controller_Request_Http) in /var/www/vhosts/wm.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Front.php on line 147
[7] in Mage_Core_Controller_Varien_Front->dispatch() in /var/www/vhosts/wm.com/httpdocs/app/Mage.php on line 424
[8] in Mage::run("default") in /var/www/vhosts/wm.com/httpdocs/index.php on line 40

 
Magento Community Magento Community
Magento Community
Magento Community
 
SeL_
Magento Team
 
Avatar
Total Posts:  1140
Joined:  2007-10-10
Paris, France
 

Hi,

I got the same problem.

I found the solution:
I had several

<remove name="catalog.compare.sidebar"/>
with the same name attribute value in one of my layout files (app/design/frontend/default/YOURTHEME/layout).
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top