Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Enabling SSL after installation
 
TechBundle
Member
 
Avatar
Total Posts:  51
Joined:  2008-03-26
 

I went into System -> Configuration -> Web and changed the Secure and Unsecure base URLs and turned on “Use Secure URLs in Frontend”. I then refreshed the cache in both my browser and Magento.

My setting for Base URL under “Unsecure” is: http://www.thisismydomain.com/ (fake address)
My setting for Base URL udner “Secure” is: https://www.thisismydomain.com/ (fake address)

I am now getting the following error in Checkout, My Account and a few other places:

“The page isn’t redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete.”

Can anyone give me a lead here?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 

Hello,

Double check that you have web server rewrites enabled in the configuration (under web).  I had a similar problem and re-enabling this option did the trick.

Kind regards,
Rick

 
Magento Community Magento Community
Magento Community
Magento Community
 
TechBundle
Member
 
Avatar
Total Posts:  51
Joined:  2008-03-26
 

Yes, web server rewrites is on.

Thanks for the fast response. Anyone else have any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Airforce111
Sr. Member
 
Avatar
Total Posts:  100
Joined:  2008-01-31
 

Did you try refreshing all your caches first?

 
Magento Community Magento Community
Magento Community
Magento Community
 
TechBundle
Member
 
Avatar
Total Posts:  51
Joined:  2008-03-26
 

Yes, I have tried refreshing the cache after the change, before the change and both. All come up with the same problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 
TechBundle - 04 April 2008 06:22 AM

I went into System -> Configuration -> Web and changed the Secure and Unsecure base URLs and turned on “Use Secure URLs in Frontend”. I then refreshed the cache in both my browser and Magento.

I don’t believe you actually have to make any changes to the ‘base urls’ - these urls are dynamically built using the bracketed values that are default.

base link url should look like this; {{secure_base_url}} —These are dynamic elements and shouldnt be replaced with hard coded values.

 
Magento Community Magento Community
Magento Community
Magento Community
 
TechBundle
Member
 
Avatar
Total Posts:  51
Joined:  2008-03-26
 

According to all past forum topics on turning on SSL after installation, Magento team members said to change the base URLs.

If I leave it at the default value, the cart works, but it never goes into secure mode, even when checking out.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 

Indeed - I’ve run across a few of these threads while researching this issue.  I guess what I dont understand is why hardcode these AND the dynamic elements.  I am certain someone will be able to clear this issue up for you shortly.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

@TechBundle, PM me your admin login if you want and I will try to check your settings.

 
Magento Community Magento Community
Magento Community
Magento Community
 
prd
Jr. Member
 
Avatar
Total Posts:  12
Joined:  2008-03-31
Plymouth, UK
 

I have been having 404 Not Found messages when the Magento moves to the secure pages. I am using a shared SSL certificate which my host provides. I have just discovered that when I switch off Web Server Rewrites in Admin / Configuration the secure pages work fine. At least the SSL pages are working now, but is there a way to achieve this with the rewrites switched on? - espcially if its is helping search engine optimisation and makes the site look cleaner.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jtyana
Jr. Member
 
Total Posts:  9
Joined:  2008-04-26
 

Thanks for posting that prd
I just turned off Web Server Rewrites and Shared SSL seems to be working now
Thank-you for sharing.

 
Magento Community Magento Community
Magento Community
Magento Community
 
shopwoc
Member
 
Total Posts:  45
Joined:  2008-10-07
 

I am having this problem, ever since I installed a GoDaddy SSL on my store and turned “Use secure URLs on Front-end” to yes any page that has https redirects to the home page.  The admin works fine with the SSL but again, any secure page on the front-end redirects back to the home page. It’s really quite frustrating as I have no idea what is causing this, it’s the only thing keeping me from taking my site live.  I’ve tried clearing my cache and turning the rewrites on and off to no avail. Any help is desperately needed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Roly
Sr. Member
 
Total Posts:  276
Joined:  2008-04-30
 

First of all, please check whether your SSL is working…

try test it by going to a simple text file eg. https://www.yourshop.com/textfile.txt ..whether it load up for you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jake99
Member
 
Total Posts:  32
Joined:  2008-10-30
 

Hello,

After installing our SSL and changing the base url for secure to https, mod_rewrite enabled. Anytime we try to hit the checkout page we get redirected to the homepage. Any thoughts?

Jake

 
Magento Community Magento Community
Magento Community
Magento Community
 
elfling
Enthusiast
 
Avatar
Total Posts:  901
Joined:  2008-10-21
 

Ok, so.. I wanna get this issue resolved once and for all.

Has ANYONE out there achieved Shared SSL that doesn’t redirect to a 404 Page Not Found screen when Mod_Rewrite is enabled.

Cos i’d really like to have mod_rewrite on.

Using Pixel Internet, they seemed happy to help at first, but looks like that wore thin quickly and said it was a magento issue.

Ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
hydra
Guru
 
Avatar
Total Posts:  378
Joined:  2008-08-26
Amsterdam
 

Hi
This is probably not the solution but you never know.
Did you disable the rewritebase line in .htaccess?
#RewriteBase /magento/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2