Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

osCommerce Migration Tool -> Connection error! Please check db configuration! 
 
Angelduster
Jr. Member
 
Total Posts:  1
Joined:  2008-04-04
 

Hallo,
habe Magento bei mir lokal via XAMPP installiert und soweit läuft auch alles recht gut.
Habe nun das am 02.04.2008 erschienene osCommerce Migration Tool installiert.

Leider bekomme ich keine Anbindung zur mySQL Datenbank hin.
Egal ob ich auf die lokale oder eine bereits auf unserem V-Server liegende zugreifen möchte, stets die gleiche Fehlermeldung:

Check requirements! Connection error! Please check db configuration!

Ich greife als root mit vollen rechten für alle hosts zu.
Ãœber mysqlfront kann ich mich problemlos mit beiden DB’s verbinden.

Jemand eine Idee woran es liegen könnte?
Im us/en Forum scheint es da keine Probleme zu geben..?

Gruß Uwe

Image Attachments
magento.gif
 
Magento Community Magento Community
Magento Community
Magento Community
 
kein-nickname
Sr. Member
 
Total Posts:  88
Joined:  2007-12-03
Germany
 

also ich hab es auf unserem server mit der alten ol-commerce (ein fork von xt-commerce 2.x) datenbank getestet und mich gewundert… fast alles wurde importiert nur hat das Tool natürlich Probleme mit Sonderzeichen… alles nach Sonderzeichen wird abgeschnitten…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Clownfish
Jr. Member
 
Total Posts:  2
Joined:  2008-01-28
 

Hallo,

vermutlich eine einfache Frage: Aber was muss unter “IP oder Hostname” eingtragen werden? Ich bekomme ebenfalls immer “Connection Error”. Magento liegt auf dem gleiche Webserver wie OSCommerce.
Habe schon über CPanel einen AccessHost zugefügt und es über diese IP-Adresse versucht. Geht aber auch nicht.
Auch www.meinedomaine.org versucht, oder localhost....

Auch komme ich mit dem verlangten Prefix nicht klar. Der User und DB heißen bei mir bspw. “jde_os”. Wobei “jde_” von CPanel bei Anlage der DB “os” vorangestellt wurde. Ist jetzt unter Prefix “jde_” einzutragen und dann als DB und Username “jde”?

Wäre für einen Tip dankbar, da ich schon etliche Kombinationen durchgespielt habe…

Jörg

 
Magento Community Magento Community
Magento Community
Magento Community
 
kein-nickname
Sr. Member
 
Total Posts:  88
Joined:  2007-12-03
Germany
 

ich habe localhost angegeben sowie den port unter port…

wenn du aber bei einem hoster eine mysql hast musst du die mysql-datenbank-domain nutzen…
z.bsp. bei 1und1

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top