Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Unterordnerinstallation macht mit .htaccess nur Probleme
 
Danubius
Jr. Member
 
Total Posts:  3
Joined:  2009-09-15
 

Hallo Freunde!
Ich habe ein schwerwiegendes Problem: Meine Magento-Installation erfolgte nach http://example.com/magento. Ich möchte aber, dass der Shop nur über http://example.com erreichbar ist, quasi intern umgeleitet, ohne das auch nur irgendjemand was davon mitbekommt, wo er wirklich liegt. Ich hatte wirklich alles ausprobiert. Schließlich sprangen die URL-s nur so durch die Gegend. Hin und her, alles war ein riesiges Chaos, und ich bin froh, dass es wenigstens so schon einmal läuft. Ins Rootverzeichnis habe ich ein .htaccess file mit folgendem Inhalt gelegt:

RewriteEngine On
#RewriteCond %{REQUEST_URI} !^/magento.*
RewriteCond %{REQUEST_URI} !^/magento/index.php/.*
RewriteRule ^(.*)$ /magento/$1 [QSA,L]

Im Magento-Hauptverzeichnis sieht meine .htaccess so aus:

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

#   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

#    php_value memory_limit 64M
    
php_value memory_limit 128M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

    
php_flag session.auto_start off

############################################
## enable resulting html compression

    
php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    
php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

    
php_flag zend.ze1_compatibility_mode Off

</IfModule>

<
IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    
SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<
IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter on all content
    
SetOutputFilter DEFLATE
    
# Insert filter on selected content types only
    #AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

    # Netscape 4.x has some problems...
    
BrowserMatch ^Mozilla/4 gzip-only-text/html

    
# Netscape 4.06-4.08 have some more problems
    
BrowserMatch ^Mozilla/4\.0[678] no-gzip

    
# MSIE masquerades as Netscape, but it is fine
    
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    
# Don't compress images
    
SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    
# Make sure proxies don't deliver the wrong content
    
Header append Vary User-Agent env=!dont-vary

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    
RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* ../index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    
AddDefaultCharset Off
    
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    
ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    
Order allow,deny
    Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none

Natürlich habe ich an den diversen Möglichkeiten herumgespielt, aber ich denke, es liegt wirklich daran, dass diese beiden Dateien sich gegenseitig nicht mögen. Garnicht davon zu sprechen, dass meine ganzen Links – auch jene, die jetzt über http://example.com zu erreichen sind – immer noch auf http://example.com/magento/ zeigen. So wird auch im Laufe des Admin-Login-Vorganges die Adresszeile von http://example.com/admin wieder zu http://example.com/magento/index.php/admin/dashboard/index/key…. Chaos Pur!

Danke für Eure Hilfe!

D.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top