Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Go Daddy CGI installation problems? 
 
essentl
Jr. Member
 
Total Posts:  12
Joined:  2007-08-31
 

I’ve gone through the posts on this topic and none have seemed to help.  At this point I am still getting “500 Internal Server Error”.
I’ve tried speaking to godaddy but they have been useless at this point. (I’m going to switch hosting when magento is ready to go)

This is what I’ve done so far:
chmod all the necessary files
dropped the php5-cgi file in my cgi folder and updated the magento .htaccess file (also chmod these files)
I do get the correct error when trying to access the cgi file on my server

I’m on a shared hosting account with hosting configuration 2.

Any help would be great!  thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bschmalz
Jr. Member
 
Total Posts:  16
Joined:  2007-09-17
Colorado Springs
 

This might be no real help, I have a dedicated GoDaddy server and I had to enable CGI inside the domain not just create a CGI-BIN folder.

Brian

 
Magento Community Magento Community
Magento Community
Magento Community
 
essentl
Jr. Member
 
Total Posts:  12
Joined:  2007-08-31
 

CGI is enabled on my server, although there isn’t a cgi-bin folder… only a cgi folder.  So i just put it there, which i think is my main problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
essentl
Jr. Member
 
Total Posts:  12
Joined:  2007-08-31
 

Ok so i finally got to the magento installation screen....smile big breakthrough. 

but now i get the following problem:
“Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2)”

 
Magento Community Magento Community
Magento Community
Magento Community
 
essentl
Jr. Member
 
Total Posts:  12
Joined:  2007-08-31
 

Got it working:) it’s great!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
WisdOMbooks
Sr. Member
 
Avatar
Total Posts:  144
Joined:  2007-08-31
Kolkata (Calcutta) - INDIA
 
essentl - 18 September 2007 08:54 AM

Got it working:) it’s great!!!

GOOD !
However… when you’ll find some little time, kindly explain in detail, for the benefit of all,
HOW you got it working,
so that people with your same problem may get help from your very solution.
Thank you smile.
 
Magento Community Magento Community
Magento Community
Magento Community
 
essentl
Jr. Member
 
Total Posts:  12
Joined:  2007-08-31
 

Sorry all,
Here is what happened. 
The problem was in my .htaccess file.  When i checked my error log is stated that there was an issue with “php_flag” statement.  So as some posts pointed out, i had to comment out (or erase) this in the .htaccess file. 

I ran into another problem when I finally got to the install screen… After selecting “I Agree” the continue button was still grayed out.  I could not continue.  Moshe noticed that i made a couple other modifications to the .htaccess file.  So I reverted back to the default .htaccess file and commented out “php_flag” statements.

My next issue was that i didn’t direct magento to the right database… After this it has worked great!  Honestly I’m a little surprised at how well it works.  I’ve read other complaints about it being a little sluggish, but mine seems to work fairly fast:)

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top