Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Custom Attributes in Product grid
 
Björn
Jr. Member
 
Total Posts:  5
Joined:  2008-04-02
 

Hi Developers,

i´ve got a little Problem with displaying some custom Attributes in the Product grid in the Categories.

In the product detail site every Attribute is in the _data array but on the category Page there are only a few attributes and no attributes that where build by my own.

Here is the Data array from the category site:

[_data:protected] => Array
                                (
                                    
[entity_id] => 1
                                    [entity_type_id] 
=> 4
                                    [attribute_set_id] 
=> 4
                                    [type_id] 
=> simple
                                    [sku] 
=> 0001
                                    [category_ids] 
=> 3
                                    [created_at] 
=> 2008-04-02 07:52:33
                                    [updated_at] 
=> 2008-04-03 08:06:57
                                    [position] 
=> 0
                                    [website_id] 
=> 1
                                    [status] 
=> 1
                                    [visibility] 
=> 4
                                    [name] 
=> Testprodukt
                                    [url_key] 
=> testprodukt
                                    [image] 
=> no_selection
                                    [small_image] 
=> no_selection
                                    [thumbnail] 
=> no_selection
                                    [price] 
=> 99.0000
                                    [special_price] 
=> 94.0000
                                    [special_from_date] 
=> 2008-04-03 08:06:57
                                    [description] 
=> Test
                                    [short_description] 
=> Test Short
                                    [tax_class_id] 
=> 2
                                    [request_path] 
=> testkategorie/testprodukt.html
                                    [stock_item] 
=> Mage_CatalogInventory_Model_Stock_Item Object

and here from the Product Detail site:

[_data:protected] => Array
        (
            
[store_id] => 1
            [entity_id] 
=> 1
            [entity_type_id] 
=> 4
            [attribute_set_id] 
=> 4
            [type_id] 
=> simple
            [sku] 
=> 0001
            [category_ids] 
=> 3
            [created_at] 
=> 2008-04-02 07:52:33
            [updated_at] 
=> 2008-04-03 08:06:57
            [name] 
=> Testprodukt
            [url_key] 
=> testprodukt
            [gift_message_available] 
=> 2
            [meta_title] 
=> 
            
[meta_description] => 
            
[image] => no_selection
            [small_image] 
=> no_selection
            [thumbnail] 
=> no_selection
            [custom_design] 
=> 
            
[url_path] => testprodukt.html
            [grundprbase] 
=> 1
            [grundpreh] 
=> kg
            [mengenmass] 
=> 10
            [weight] 
=> 0.0000
            [price] 
=> 99.0000
            [special_price] 
=> 94.0000
            [description] 
=> Test
            [short_description] 
=> Test Short
            [meta_keyword] 
=> 
            
[custom_layout_update] => 
            
[news_from_date] => 2008-04-01 00:00:00
            [news_to_date] 
=> 2008-04-17 00:00:00
            [special_from_date] 
=> 2008-04-03 08:06:57
            [status] 
=> 1
            [visibility] 
=> 4
            [tax_class_id] 
=> 2
            [media_gallery] 
=> Array

Here you can see that the Attribute grundprbase is in the Product details but not in the Product Grid.

Has anybody an idea how i can make my own attributes run on the product grid ?

I´ve tried the solution that is in the Wiki but it doesn´t run too.

best regards

Björn

 
Magento Community Magento Community
Magento Community
Magento Community
 
patriveri
Jr. Member
 
Total Posts:  30
Joined:  2008-02-23
 

Bjorn,

You need to add the attributes in the layout.

I found the following thread very useful: http://www.magentocommerce.com/boards/viewthread/1610/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top