Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Firefox is playing up displaying my website. 
 
Seong
Member
 
Total Posts:  62
Joined:  2008-12-12
 

Hi,

Everything displays absolutely fine in IE browsers but only in Firefox, the top menu shows up funny.

If you see the attached images, you will see what I mean.

I want to keep them consistent throughout all the browsers.

Can anyone help with some codings I need to add in specific css or xml files?

Thank you.

I am desperate for help!

Image Attachments
fine.jpgproblem.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
clorne
Sr. Member
 
Total Posts:  236
Joined:  2008-01-10
London
 

I think you will find that your site will appear incorrectly in quite a few browsers including IE8 (image attached), Chrome and FF.

Try adding clear:both to your menu.css about line 24

#nav {
clear:both;
font-size:1.1em;
padding:0 20px;
}

Image Attachments
manuk.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Seong
Member
 
Total Posts:  62
Joined:  2008-12-12
 
clorne - 03 September 2009 05:29 AM

I think you will find that your site will appear incorrectly in quite a few browsers including IE8 (image attached), Chrome and FF.

Try adding clear:both to your menu.css about line 24

#nav {
clear:both;
font-size:1.1em;
padding:0 20px;
}

Oh it is a big problem it this appears in many browsers..
I tried your coding but it looks the same…

Please help..

 
Magento Community Magento Community
Magento Community
Magento Community
 
clorne
Sr. Member
 
Total Posts:  236
Joined:  2008-01-10
London
 

Your site now appears correctly on all browsers.  Did you change something else?

Image Attachments
manuk.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Seong
Member
 
Total Posts:  62
Joined:  2008-12-12
 
clorne - 03 September 2009 09:45 PM

Your site now appears correctly on all browsers.  Did you change something else?

It didn’t appear correctly until yesterday with your coding added but it looks fine now.
I believe your coding was the right answer to my question!

Thanks a lot

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top