Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PROBLEM: Indizierung von Artikel Preisen “Fehler beim Neuaufbau.”
 
ronald_fenk
Jr. Member
 
Total Posts:  1
Joined:  2013-06-05
 

Hallo Zusammen!

Die Indizierung von Artikel Preisen funktioniert nicht. Leider habe ich nicht die Möglichkeit per Shell auf den Server zuzugreifen. Habe es auch schon mit PHP Scripts probiert - keine Lösung! Was soll ich tun???

Image Attachments
Bildschirmfoto 2013-09-02 um 21.44.53.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
copyabd
Jr. Member
 
Total Posts:  9
Joined:  2010-06-19
 

Hallo,

ich hänge mich einfach mal hier dran, da ich das gleiche Problem habe.

Alle Index lassen sich neu aufbauen bis auf die Preise.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siggi_Schmitz
Enthusiast
 
Avatar
Total Posts:  811
Joined:  2011-07-03
 

Hast du denn die Möglichkeit den indexer über die Konsole zu starten?
Irgendwelche Fehlermeldungen in var/log/system.log oder var/log/exception.log wenn du den Indexer ausführst? System logging vorher im backend aktivieren.

 
Magento Community Magento Community
Magento Community
Magento Community
 
marketingsued
Jr. Member
 
Total Posts:  5
Joined:  2013-04-30
 
Siggi_Schmitz - 12 September 2013 03:10 AM

Hast du denn die Möglichkeit den indexer über die Konsole zu starten?
Irgendwelche Fehlermeldungen in var/log/system.log oder var/log/exception.log wenn du den Indexer ausführst? System logging vorher im backend aktivieren.

Hallo,
ich habe das selbe Problem. Wie ist dieser Fall ausgegangen?

Ich kann ebenfalls den Preisindex nicht Neuaufbaues
(Ich habe im Moment nur ein Testprodukt, nachdem ich es gelöscht habe funktioniert es auch nicht)

Ergänzung: Bei mir hat sich das Problem von selbst über Nacht gelöst.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jacko11
Jr. Member
 
Total Posts:  1
Joined:  2014-02-26
 

Auch ich hab das Problem - jemand mittlerweile eine Lösung gefunden?

 
Magento Community Magento Community
Magento Community
Magento Community
 
robin2160
Mentor
 
Avatar
Total Posts:  1046
Joined:  2009-02-15
Berlin / Germany
 

Du kannst folgendes versuchen.
Meistens liegt es daran das in der Staffelpreistabelle einen oder mehrere Datensätze gibt die auf eine nicht mehr existierende Produkt-ID verweisen (der Artikel wurde wohl nicht ordungsgemäß gelöscht).
Führe diesen SQL-Befehl (z.B. via phpMyAdmin) aus. Hier werden die Staffelpreiseinträge gelöscht die keiner Produkt-ID mehr zuzuordnen sind.

DELETE FROM catalog_product_entity_tier_price WHERE entity_id NOT IN (SELECT entity_id FROM catalog_product_entity);

Dannach via ftp oder ssh das Verzeichnis var/locks leeren (nicht löschen) und die Indizierung dann nochmal versuchen.
Und wie immer: Vor allen vorher eine DB-Sicherung machen !

VG Stefan

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top