Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

the page does not show my css styles
 
Andrea, Argentina
Sr. Member
 
Total Posts:  164
Joined:  2007-12-05
Buenos Aires, Argentina
 

Hi all there!

I have installed version 1.0. I did a fresh install because did’n want to overwrite the earlier demo. When I configured the design to show my theme / layout / skins with my particular theme the page shows images but doesn’t show CSS styles.

Any idea?

I was using my theme in earlier version without any problem (8.17)

Thank you
Andrea

 
Magento Community Magento Community
Magento Community
Magento Community
 
NickL
Sr. Member
 
Avatar
Total Posts:  188
Joined:  2007-08-31
 

Are you sure your CSS is being called in the head?

check head.phtml under templates / page / html /

Most likely your styles are not being called…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andrea, Argentina
Sr. Member
 
Total Posts:  164
Joined:  2007-12-05
Buenos Aires, Argentina
 

It is very strange… The images that shows my page after configuring my own theme are right. But it seems as it doesn’t find or call my css files!! They are in the proper folder, and I have checked with my hosting provider and they see my own files. Then, I don-t understand what is it happening and I haven’t this problem before. Imagine I am trying to launch my e/cmmerce site and can not even try it at all now.

Thank you
Andrea

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andrea, Argentina
Sr. Member
 
Total Posts:  164
Joined:  2007-12-05
Buenos Aires, Argentina
 

Hi guys, I need help with this, I’ve just finished my first demo store and when I began with a clean install of version 1.0 the CSS aren’t working. I am sure about the theme I put in configuration because the images changed and so the layout… the problem is only with the css styles!! Its very strange and I can’t move without community or team members help.

Andrea

(I’ve posted this issue two days ago and only one person tried to help me, that is very strange too)

 
Magento Community Magento Community
Magento Community
Magento Community
 
mayerwin
Sr. Member
 
Avatar
Total Posts:  182
Joined:  2008-01-15
France
 

If you call your css stylesheet in the page.xml layout file, you should use this:
<action method="addCss"><link>css/mystylesheet.css</link></action>

The syntax has changed to <link> (before it was only <css>).
Hope it helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andrea, Argentina
Sr. Member
 
Total Posts:  164
Joined:  2007-12-05
Buenos Aires, Argentina
 

Hi Mayerwin, thank you for post.
I’m not call my css styles. Magento does. I don’t touch any xml file in this version. Only in the control panel for admin, change the Design by website, store view, etc., applying my theme name.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mayerwin
Sr. Member
 
Avatar
Total Posts:  182
Joined:  2008-01-15
France
 

There’s something that is important: have you disabled ALL the cache? As for me, I couldn’t find out why the layout + CSS wasn’t displayed properly, until I tried this, and it worked perfectly. So clean and disable everything in the cache management.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andrea, Argentina
Sr. Member
 
Total Posts:  164
Joined:  2007-12-05
Buenos Aires, Argentina
 

I did.
But there is something strange with this feature in version 1.0
I select the option “All cache: disable” in the first dropdown menu, but when save configuration it appears the same as in the beginning. The selection does not remain. Don’t know why this is happening both Explorer and Firefox.

BUT I think this is not a cache problem because the layout and images load without any problem.
Can you see it at vinosyplaceres.com/magento ?
Maybe you can see something there :(

Thank you very much!!
Andrea

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andrea, Argentina
Sr. Member
 
Total Posts:  164
Joined:  2007-12-05
Buenos Aires, Argentina
 

STRANGE:
When I set the design of my store view to load my theme it seems that the page doesn’t load ANY css styles!!! ??? (I was searching if there was a cache problem again but I realize that the issue is not if the css loads, but there is any css loading in the page).
If I set the default theme, everything works fine…

I am driving crazy, in earlier versions it worked so fine!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
mayerwin
Sr. Member
 
Avatar
Total Posts:  182
Joined:  2008-01-15
France
 

Well, when you look at the source code, you can see that none of the .css stylsheet have been loaded. Nor are .js scriptsheets. So it seems that the relevant xml file (probably page.xml) was not loaded.

Does it work well with the default theme? If yes, then the problem comes from you theme structure or content. Note that some things have changed since the previous version. I can help you if you PM me your FTP access.

Good luck

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andrea, Argentina
Sr. Member
 
Total Posts:  164
Joined:  2007-12-05
Buenos Aires, Argentina
 

"Note that some things have changed since the previous version.”

There should be the problem then.
¿Where have you read about the things that have changed since the previous version?
¿How to know what things?

 
Magento Community Magento Community
Magento Community
Magento Community
 
mayerwin
Sr. Member
 
Avatar
Total Posts:  182
Joined:  2008-01-15
France
 

Well, it’s not exactly the folder structure, but some specifications of the files. The best I can do for you is to have a look at your theme files. Either you can send them to me by email or give me the FTP access.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andrea, Argentina
Sr. Member
 
Total Posts:  164
Joined:  2007-12-05
Buenos Aires, Argentina
 

mayerwin thanks!!!

I haven’t my info here neither my ftp info nor my files because i’m in another computer.

I think the best way is to open the files again and see if I discover the changes.

Tomorrow I’ll contact you sure.
You are a programmer aren’t you? What’s your job? Maybe you can teach/help me some about Magento templates and blocks. If I can afford your classes, it would be very very good.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mayerwin
Sr. Member
 
Avatar
Total Posts:  182
Joined:  2008-01-15
France
 

I replied you by email. FYI, I am a developer as a part time activity, since I am also a trader and entrepreneur. 
I learn more about Magento each day so if I can help you understanding it better I will be glad to do so. But reading the Designer’s guide is a first step you should not miss.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top