Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problema visualizzazione immagini prodotti
 
Jarbis
Jr. Member
 
Total Posts:  8
Joined:  2013-08-02
 

Ho notato che caricando le immagini di alcuni prodotti (1,5 MB circa) queste non vengono visualizzate nel frontend. Le immagini sono correttamente caricate sul server, perché nella pagina del prodotto nel lato amministrativo riesco a visualizzarle. Può dipendere da qualche impostazione di magento?

 
Magento Community Magento Community
Magento Community
Magento Community
 
giggi91
Sr. Member
 
Total Posts:  227
Joined:  2012-02-09
 

La dimensione massima delle foto prodotti solitamente è di 2 MB
Ad ogni modo puoi settarla, se sei su server dedicato, tramite il file php.ini modificando le impostazioni di post_max_size e upload_max_filesize

Bye bye

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jarbis
Jr. Member
 
Total Posts:  8
Joined:  2013-08-02
 

Secondo me però non dipende dal server, perché l’immagine viene caricata e nella pagina di amministrazione la vedo, il problema è che poi non viene visualizzata nel negozio. Può comunque dipendere dalle impostazioni del server?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

può anche essere che Magento non riesca a generare le miniature. Prova a vedere quale è il percorso generato nel frontend e scrivilo qua così vediamo un pò (oppure se ci dai il link tanto meglio rasberry)

 
Magento Community Magento Community
Magento Community
Magento Community
 
giggi91
Sr. Member
 
Total Posts:  227
Joined:  2012-02-09
 

Se te le fa vedere nel backend allora non credo sia un problema del server. Controllato di aver settato i giusti permessi sulla cartella Media?
Ti ricordo che i file devono essere 664 e le cartelle 775
Ciao smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jarbis
Jr. Member
 
Total Posts:  8
Joined:  2013-08-02
 

Ecco i link della pagina prodotto nel frontend (album-con-borsa-in-cuoio-rigenerato-355.html) e dell\’immagine caricata (media/catalog/product/d/a/dante.jpg).

 
Magento Community Magento Community
Magento Community
Magento Community
 
TreInnova
Guru
 
Avatar
Total Posts:  465
Joined:  2009-02-20
Fano
 
Jarbis - 01 September 2013 03:06 AM

Ecco i link della pagina prodotto nel frontend (http://www.fotoideedigitali.com/album-con-borsa-in-cuoio-rigenerato-355.html) e dell\’immagine caricata (http://www.fotoideedigitali.com/media/catalog/product/d/a/dante.jpg).

Ciao giusto per toglierci ogni problema tu hai assegnato le immagini nel backend a baseimage,small image e thumbnail?
saluti
fe.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jarbis
Jr. Member
 
Total Posts:  8
Joined:  2013-08-02
 
TreInnova - 01 September 2013 09:49 PM

Ciao giusto per toglierci ogni problema tu hai assegnato le immagini nel backend a baseimage,small image e thumbnail?
saluti
fe.

Si le immagini le ho assegnate.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

puoi farci lo screenshot della view del pannello delle immagini?

Eventualmente fai questi due tentativi:

- imposta il tema default e vedi se viene mostrata l’immagine
- Attiva i log e vedi se c’è qualche errore connesso alle immagini.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jarbis
Jr. Member
 
Total Posts:  8
Joined:  2013-08-02
 
Black Cat - 02 September 2013 01:59 PM

puoi farci lo screenshot della view del pannello delle immagini?

Eventualmente fai questi due tentativi:

- imposta il tema default e vedi se viene mostrata l’immagine
- Attiva i log e vedi se c’è qualche errore connesso alle immagini.

Ho provato entrambe le cose ma niente, i log non segnalano alcun problema e con il tema di default le immagini non si vedono.

PS. mi sono appena accorto che il numero di prodotti segnato vicino ai nomi delle categorie nel frontend non è corretto, mentre nel pannello di amministrazione vengono conteggiati correttamente… Che le due cose siano collegate?

Image Attachments
admin.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

Verifica anche che il server supporti la libreria GD, che la cartella media e le sue sottocartelle (e i file) posseggano i giusti permessi e prova anche con qualche immagine di bassa qualità (se hai caricato immagini di alta qualità e il tuo memory limit è basso la creazione delle immagini potrebbe non essere portata a termine.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jarbis
Jr. Member
 
Total Posts:  8
Joined:  2013-08-02
 

Per quanto riguarda immagini di bassa qualità ho già verificato, vengono visualizzate senza problemi. Per il resto verifico e vi faccio sapere.

 
Magento Community Magento Community
Magento Community
Magento Community
 
giggi91
Sr. Member
 
Total Posts:  227
Joined:  2012-02-09
 

Prova ad andare nel file .htaccess e settare
php_value memory_limit 64M
php_value max_execution_time 18000

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jarbis
Jr. Member
 
Total Posts:  8
Joined:  2013-08-02
 
giggi91 - 03 September 2013 01:34 AM

Prova ad andare nel file .htaccess e settare
php_value memory_limit 64M
php_value max_execution_time 18000

Ho verificato il file è già settato in questo modo…

Black Cat - 03 September 2013 01:09 AM

Verifica anche che il server supporti la libreria GD, che la cartella media e le sue sottocartelle (e i file) posseggano i giusti permessi e prova anche con qualche immagine di bassa qualità (se hai caricato immagini di alta qualità e il tuo memory limit è basso la creazione delle immagini potrebbe non essere portata a termine.

Ho controllato e il server supporta la libreria GD. Inoltre ho controllato i permessi e sono corretti. Caricando immagini di bassa qualità (meno di 1MB) non si verificano problemi!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

ohibò così su due piedi non mi viene in mente altro, se tutto è stato controllato, compreso la cache e gli indici non saprei :/

Proova di nuovo con reindici e pulizia totale di tutte le cache. Il file di log è proprio vuoto?

 
Magento Community Magento Community
Magento Community
Magento Community
 
giggi91
Sr. Member
 
Total Posts:  227
Joined:  2012-02-09
 

Prova ad aumantare anche il valore del post_max_size e del upload_max_filesize e del memory_limit portando tutto a 128MB sempre nel php.ini.
Se lavori in locale dai una bella riavviata al server web e svuota la cache sia tramite il backend che cancellando fisicamente la cartella cache e session all’interno della cartella var del tuo Magento
Fammi sapere, ciao smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top