Magento Forum

   
Page 4 of 4
PHP Extension “curl” must be loaded ? 
 
ranjanibs
Jr. Member
 
Total Posts:  1
Joined:  2013-08-26
 

PHP extension “curl” must be loaded.
Still doesnot work after i have done changes by removing comment for “;extension=php_curl.dll” in php.ini

 
Magento Community Magento Community
Magento Community
Magento Community
 
Pulkit Seth
Sr. Member
 
Avatar
Total Posts:  107
Joined:  2011-08-18
 

Hi,

Are you working on local System or live server ? Please try to restart your server, and then install magento from the beginning, dont refresh the same error page, i think it should work after restarting the server.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
zesttech
Member
 
Total Posts:  31
Joined:  2012-04-30
London, UK
 

grin Hello Buddy,

If you are using Debian or Linux based systems , then you can try using this :
sudo apt-get install php5-curl sudo /etc/init.d/apache2 restart
For RedHat/CentOS based systems you can try using this as root :
yum install php5-curl /etc/init.d/httpd restart
I think this will work for you
grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
andersoliver
Jr. Member
 
Total Posts:  4
Joined:  2013-08-27
 

I’m new to Magento, but editing my php.ini file & uncommenting the following resolved my problem.

extension=php_curl.dll

BTW, this was done on a local server using WAMP. Thanks.
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Micose de Unha

 
Magento Community Magento Community
Magento Community
Magento Community
 
andersoliver
Jr. Member
 
Total Posts:  4
Joined:  2013-08-27
 

Go to php.ini file
problem 1 PHP Extension “curl” must be loaded
and find
;extension=php_curl.dll
and remove semicolon
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- Jogos de Estacionamento

 
Magento Community Magento Community
Magento Community
Magento Community
 
jinzzc
Jr. Member
 
Total Posts:  1
Joined:  2013-09-25
 

I’m using Windows Server IIS 7 X64
wampserver2.2e-php5.3.13-httpd2.2.22-mysql5.5.24-x64
I changed all php_curl.dll in php.ini I’m still having trouble.
I even replace the php_curl.dll file..

any suggestion??

Thank you

 
Magento Community Magento Community
Magento Community
Magento Community
 
senlinliang
Jr. Member
 
Total Posts:  4
Joined:  2012-12-05
 

you must enable the extension in directory ...xampp\apache\bin
in file php.ini
this must be removed ;
extension=php_curl.dll
and it must work

 
Magento Community Magento Community
Magento Community
Magento Community
 
imtihoss
Jr. Member
 
Total Posts:  1
Joined:  2013-11-18
 

If you’re using WAMP… go WAMP>bin>apache>ApacheX.X.X>bin

In this folder, you should be able to find a PHP config file. Double click, search “curl” and it should show you extension=php_curl.dll

Just remove the semicolon that comes before it and you’re good to go for now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Shakaib
Jr. Member
 
Total Posts:  1
Joined:  2013-12-18
 

I was facing the same problem even after uncomment this line
extension = php_curl.dll
from Php\Php.VX\php.ini & apache\apache.VX\bin\php.ini but thanks to the guy who has solved my problem.
Here is the link
http://teclp.com/2013/01/magento-php-curl-extension-wamp/

 
Magento Community Magento Community
Magento Community
Magento Community
 
xvip87
Jr. Member
 
Total Posts:  5
Joined:  2013-11-03
 

you need add extension = php_curl.dll to your php.ini

 
Magento Community Magento Community
Magento Community
Magento Community
 
jariwaladimpi
Jr. Member
 
Total Posts:  1
Joined:  2014-02-17
 
senlinliang - 27 September 2013 06:21 PM

you must enable the extension in directory ...xampp\apache\bin
in file php.ini
this must be removed ;
extension=php_curl.dll
and it must work

I am working on WAMP and I did the process you specified, restarted WAMP still was not working. Then I restarted my PC but still the error sustains. Now What can I do? My WAMP server version is 2.2. My Magento version is 1.8.1.0

 
Magento Community Magento Community
Magento Community
Magento Community
 
gauravkhokhar
Jr. Member
 
Total Posts:  1
Joined:  2014-03-11
 

go to PHP ini file and search curl

remove ;

semicolon from the line and restart the wamp your problem will be solve.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rocketero
Jr. Member
 
Total Posts:  9
Joined:  2011-01-29
 
Thunderm00n - 06 April 2008 11:17 PM

Figoured out that under Xamp and Xp the extension curl must be enabled under xamproot\apache\bin\php.ini not under xamproot\php\php.ini

Ditto!  thanks

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 4 of 4