Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PHP Extension “curl” must be loaded ? 
 
luzambelli
Jr. Member
 
Total Posts:  1
Joined:  2010-10-02
 
mrobo - 06 January 2009 10:58 AM

TO ALL WHICH DON’T WORKS IT ON XAMPP
you must enable the extension in directory ...xampp\apache\bin
in file php.ini
this must be removed ;
extension=php_curl.dll
and it must work

I did this and i’m having the same problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
maozinha
Jr. Member
 
Total Posts:  1
Joined:  2011-09-26
 
Thunderm00n - 06 April 2008 11:17 PM

Figoured out that under Xamp and Xp the extension curl must be enabled under xamproot\apache\bin\php.ini not under xamproot\php\php.ini

thaaaanks =DD

 
Magento Community Magento Community
Magento Community
Magento Community
 
moonriver
Jr. Member
 
Total Posts:  7
Joined:  2010-02-03
 

Yes ,curl must be installed. You can search from google.

 
Magento Community Magento Community
Magento Community
Magento Community
 
janfool
Jr. Member
 
Total Posts:  1
Joined:  2012-04-16
 

sssssssssssshhhhhhhhhhhhhhhhiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiittttttttttttttttttttttttttttttttttttttttttttt
fuck CMS it’s hard for beginners to do this fucking

1. Go to the file php.ini
2. Search for ;extension=php_curl.dll
3. Remove semicolon and restart server. It will work.

PHP extension “curl” must be loaded.
PHP extension “curl” must be loaded.
PHP extension “curl” must be loaded.

Fuk u to all who made This CMS

 
Magento Community Magento Community
Magento Community
Magento Community
 
sguru
Jr. Member
 
Total Posts:  1
Joined:  2012-04-18
 

Hey it is very simple;

Go to your Php ini file file this line and un comment it “extension=php_curl.dll”;

Thats all.

Thanks

ZuckaS - 07 November 2007 08:38 PM

I am trying to configure Magento on Ubuntu 7.10. Everything is set up except for curl.

Does anyone know how to enable it?

This is what I’m getting:
PHP Extension “curl” must be loaded

That’s the only error that I get when I launch the installation wizard. Everything else seem fine.

Anyone? Thanks…

Z

 
Magento Community Magento Community
Magento Community
Magento Community
 
davy_yg
Jr. Member
 
Total Posts:  17
Joined:  2012-03-07
 

Hi,

I am having the same problem.  I just cannot find php.ini file in apache/bin

 
Magento Community Magento Community
Magento Community
Magento Community
 
sorinaina71
Jr. Member
 
Total Posts:  1
Joined:  2012-06-13
 

Still doesn’t work!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
avadhoot221266
Jr. Member
 
Total Posts:  1
Joined:  2012-07-26
 

C-->xampp-->php-->php.ini(Configuration Settings File)--> Un-comment “ ;extension=php_curl.dll” i,e remove “ ; “. Restart all services. Done

 
Magento Community Magento Community
Magento Community
Magento Community
 
birvashah
Jr. Member
 
Total Posts:  3
Joined:  2011-08-22
 

Hi,

Search extension=php_curl.dll line in php.ini file and remove ;(semicolon) .

Then try copying the libeay32.dll and ssleay32.dll files from your PHP installation and put them into your Apache /bin directory.

Restart apache.

This worked for me.

Hope will help you.

Thanks,
Birva

 
Magento Community Magento Community
Magento Community
Magento Community
 
liton74
Jr. Member
 
Total Posts:  1
Joined:  2012-11-12
 

Hi.

I’m currently trying to install Magento Community 1.7 on Windows following the instructions given in the Magento Community 1.7

I got a validation error for three extensions when running the downloader -"” PHP Extension “curl” must be loaded “”. Here’s how I fixed it:

1. Open php.ini in notepad.
2. Locate Dynamic Extensions Section.
3. Remove semi-colon from the beginning of each instruction referring to the PHP extension throwing the error.
4. Save and exit.
5. Stop and Re-start Apache Web Server.
6. Re-validate in the downloader.

Everything worked.

Hope this helps.

Image Attachments
php.ini.jpeg
 
Magento Community Magento Community
Magento Community
Magento Community
 
floweriux
Newbie
 
Total Posts:  0
Joined:  2013-03-23
 

You can find answer her:
http://stackoverflow.com/questions/10939248/php-curl-not-working-wamp-on-windows-7-64-bit

 
Magento Community Magento Community
Magento Community
Magento Community
 
prembaranwal
Jr. Member
 
Total Posts:  1
Joined:  2013-05-26
 

Solution is here:
awesomesirjee.blogspot.in/2013/05/php-extension-curl-must-be-loaded.html

 
Magento Community Magento Community
Magento Community
Magento Community
 
mi2aryan
Jr. Member
 
Total Posts:  1
Joined:  2013-08-03
 

PHP extension “curl” must be loaded.

Here is simple screen shot..

 
Magento Community Magento Community
Magento Community
Magento Community
 
bartom34
Jr. Member
 
Total Posts:  18
Joined:  2011-10-25
 

it does’nt work for me !

 
Magento Community Magento Community
Magento Community
Magento Community
 
bartom34
Jr. Member
 
Total Posts:  18
Joined:  2011-10-25
 
mrobo - 06 January 2009 10:58 AM

TO ALL WHICH DON’T WORKS IT ON XAMPP
you must enable the extension in directory ...xampp\apache\bin
in file php.ini
this must be removed ;
extension=php_curl.dll
and it must work

It does’nt work for me !

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top