Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 4
PHP Extension “curl” must be loaded ? 
 
skippybosco
Enthusiast
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

don’t forget to restart appache web server after changing the php.ini grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
deepakg_10
Jr. Member
 
Total Posts:  2
Joined:  2009-02-22
 
Primary Numbers - 16 September 2007 05:18 PM

thanks for all the help! smile finally figured it al out.

plz reply hows you solved this problem?

 
Magento Community Magento Community
Magento Community
Magento Community
 
mhunkler
Guru
 
Total Posts:  304
Joined:  2009-05-30
 
mrobo - 06 January 2009 11:06 AM

TO ALL WHICH DON’T WORKS IT ON XAMPP
you must enable the extension in directory ...xampp\apache\bin
in file php.ini
this must be removed ;
extension=php_curl.dll
and it must work
cheese

There is no php.ini in my xampp\apache\bin folder....

 
Magento Community Magento Community
Magento Community
Magento Community
 
ckosny
Guru
 
Total Posts:  349
Joined:  2009-02-28
Luxembourg
 

@mhunkler

Are you sure?This would be quite unusual for xampp (we are talking about the xampp from apachefriends aren’t we?).
Does your OS display the file extensions?On most windows systems this is disabled by default, so depending on your settings you might just see a file called ‘php’.
Be that as it may - simply search your entire file system for the php.ini file (you might find several, in this case just apply the required changes to all).

Good luck

Claudia

 
Magento Community Magento Community
Magento Community
Magento Community
 
skippybosco
Enthusiast
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

In 1.7.1 they moved it to xampp\php\php.ini

you can always browse to http://127.0.0.1/xampp/phpinfo.php and check where the loaded configuration file is being read from.

 
Magento Community Magento Community
Magento Community
Magento Community
 
nanhe
Jr. Member
 
Total Posts:  6
Joined:  2008-05-19
 

hi
Go to php.ini file
problem 1 PHP Extension “curl” must be loaded
and find
;extension=php_curl.dll
and remove semicolon

problem 2 PHP Extension “mcrypt” must be loaded
and fined
;extension=php_mcrypt.dll

remove semicolon and restart your server

thanks
9311114882

 
Magento Community Magento Community
Magento Community
Magento Community
 
bigtyne
Jr. Member
 
Total Posts:  2
Joined:  2008-09-18
 

Hello,

I am trying to instal Magento on my vista laptop using xampp. I followed the link here http://www.magentocommerce.com/wiki/general/installing_on_windows_with_xampp_and_wamp to get going.

After editing the Edit apache/conf/httpd.conf file and the apache/bin/php.ini files all was going well.

When i go tohttp://localhost/magento/index.php/install/ to run through the instalation process for magento for some reason I cant change the localisation setting they always jump back to the default settings. So I click continue anyway thinking this can be changed at a later date.

On the Configuration Section in the Instalation I get an error “PHP Extension “curl” must be loaded”. So I double check the original apache/conf/httpd.conf file and apache/bin/php.ini files and they are all correct.

I have hit a brick wall here.

Any help would be fantastic.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rzkhan
Jr. Member
 
Total Posts:  2
Joined:  2009-12-23
 

PHP Extension “curl” must be loaded,i want to install on windows (os) that time i face this problem.Please solve this problem

Image Attachments
problem.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Sam Wilson
Jr. Member
 
Total Posts:  5
Joined:  2010-05-06
Marblehead, MA
 

Environment:

O/S: Windows XP Professional
PHP: php-5.3.2-Win32-VC6-x86
Apache: httpd-2.2.15-win32-x86-no_ssl
MySQL: mysql-5.1.46-win32

When I installed PHP it was not able to update httpd.conf. So, I added the following to the httpd.conf:

LoadModule php5_module “C:/CustomApps/PHP/php5apache2_2.dll”

# configure the path to php.ini
PHPIniDir “C:/CustomApps/PHP”

AddType application/x-httpd-php .php

************************************************
PHP installation directory and extension directory has the following DLL:

C:\CustomApps\PHP\libeay32.dll
C:\CustomApps\PHP\ssleay32.dll
C:\CustomApps\PHP\ext\php_curl.dll

I see following configuration in my php.ini

[PHP_CURL]
extension=php_curl.dll

************************************************

I still get the following error why i run Magento downoader “PHP Extension “curl” must be loaded”. Any help to fix this issue will be greatly appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
SvenV
Jr. Member
 
Total Posts:  8
Joined:  2009-01-11
 

Hi, Sam!

Double check your apache error log. I was thinking that CURL is working. phpinfo() SOMETIMES also showed that curl is OK. Apparently it was not OK because I had some wrong versions of libeay32.dll and ssleay32.dll in my windows/system32 directory. I copied those over with the original ones from PHP package and it’s working fine now.

So double check if curl extension is really loaded.

 
Magento Community Magento Community
Magento Community
Magento Community
 
belove
Jr. Member
 
Total Posts:  1
Joined:  2010-07-14
 

i am also have the same problem , but i cant find the xampp/apache/bin/ php.ini
i just found that xampp/php/php.ini’
can anyone help me ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
shahid_khan_hall
Jr. Member
 
Total Posts:  1
Joined:  2010-07-16
 
Primary Numbers - 16 September 2007 01:19 PM

How do I go about getting this to happen, this is the error message I’m getting when I try and do the install..

 
Magento Community Magento Community
Magento Community
Magento Community
 
byronbear
Jr. Member
 
Total Posts:  1
Joined:  2010-07-16
 

I can tell you as a host that most reputable hosts are going to have PHP locked down to where you’re not allowed to load extensions. It is a huge security issue if you let your users load extensions, as you may have a nefarious user that attempts to load a malicious extension.
Acai Optimum

 
Magento Community Magento Community
Magento Community
Magento Community
 
shetty
Jr. Member
 
Total Posts:  2
Joined:  2010-08-01
 

...xampp\apache\bin
in file php.ini
this must be removed ;
extension=php_curl.dll

Never forget to Restart Apache web server

 
Magento Community Magento Community
Magento Community
Magento Community
 
shetty
Jr. Member
 
Total Posts:  2
Joined:  2010-08-01
 

...xampp\apache\bin
in file php.ini
remove ;
extension=php_curl.dll

Restart Apache server

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 4