Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 4
PHP Extension “curl” must be loaded ? 
 
Primary Numbers
Jr. Member
 
Total Posts:  17
Joined:  2007-09-03
 

How do I go about getting this to happen, this is the error message I’m getting when I try and do the install..

 
Magento Community Magento Community
Magento Community
Magento Community
 
jsperri
Sr. Member
 
Total Posts:  126
Joined:  2007-08-31
Fistufle
 

According to the changelog, last Magento release (0.6.12510) installation wizard now checks for curl on setup.
Make sure curl extension is enabled in your php.ini
Check the line refering to php_curl.dll uncomment it and restart your web server.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ShenoudaB
Jr. Member
 
Total Posts:  5
Joined:  2007-09-15
 

copy the libeay32.dll , ssleay32.dll from the extracted PHP Folder to the path of PHP ex: Program Files/PHP/
and the same with php_curl.dll copy it form from the extracted PHP Folder to the path of PHP ex: Program Files/PHP/ext/

with taking in your concern the previous replay
and restart the apache,

hoping that helps you,

Shenouda Bertel
Software Developer

 
Magento Community Magento Community
Magento Community
Magento Community
 
Primary Numbers
Jr. Member
 
Total Posts:  17
Joined:  2007-09-03
 

I’m sorry but I’m not following you.  I have XAMPP installed.. when u say extracted php folder… i’m assumin gu want me to move some of the dlls to the ext folder..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Primary Numbers
Jr. Member
 
Total Posts:  17
Joined:  2007-09-03
 

let me clarifty i found the libeay32.dll and the ssleay32.dll and got those moved.. but i don’t know where the php_curl.dll is found..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Primary Numbers
Jr. Member
 
Total Posts:  17
Joined:  2007-09-03
 

thanks for all the help! smile finally figured it al out.

 
Magento Community Magento Community
Magento Community
Magento Community
 
YoavKutner
Guru
 
Avatar
Total Posts:  491
Joined:  2007-08-08
 

I updated the XAMMP installation on the Wiki on Friday here http://www.magentocommerce.com/wiki/Installing-on-Windows-with-XAMPP-and-WAMP/

Thanks

yoav

 
Magento Community Magento Community
Magento Community
Magento Community
 
ZuckaS
Member
 
Total Posts:  37
Joined:  2007-10-16
 

I am trying to configure Magento on Ubuntu 7.10. Everything is set up except for curl.

Does anyone know how to enable it?

This is what I’m getting:
PHP Extension “curl” must be loaded

That’s the only error that I get when I launch the installation wizard. Everything else seem fine.

Anyone? Thanks…

Z

 
Magento Community Magento Community
Magento Community
Magento Community
 
ZuckaS
Member
 
Total Posts:  37
Joined:  2007-10-16
 

I just figured it out…

Just do:
sudo apt-get install php5-curl

It works now!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Thunderm00n
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2007-11-02
Essen, Germany
 

Figoured out that under Xamp and Xp the extension curl must be enabled under xamproot\apache\bin\php.ini not under xamproot\php\php.ini

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

Also, iconv must be loaded too. The system requirements page should include both cURL and iconv. Even though both of those are typically bundled with most PHP installations, it’s still a good idea to add them to the list.

 
Magento Community Magento Community
Magento Community
Magento Community
 
nadshez
Member
 
Avatar
Total Posts:  48
Joined:  2008-04-16
 

I’m new to Magento, but editing my php.ini file & uncommenting the following resolved my problem.

extension=php_curl.dll

BTW, this was done on a local server using WAMP. Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
davinder
Member
 
Total Posts:  56
Joined:  2008-06-26
 

i m doing installation on my local WAMP as well but cant go beyond this issue although I followed all the steps related to editing php.ini file.

 
Magento Community Magento Community
Magento Community
Magento Community
 
excentricus
Jr. Member
 
Total Posts:  1
Joined:  2008-10-28
 

Greetings All!

I’m new here & this is my first post.

I’ve just installed magento as well on xampp and was getting the same error message, although I followed all instructions
for proper installation. I stumbled on few answers saying to restart the service, the local server, which to my surprise worked!

Surprise, because I have a few different CMS’s running locally on xampp and I never had to do this before running into similiar
problems.

Anywayw, just shut down all services and restart. It may work for you as well.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mrobo
Jr. Member
 
Total Posts:  5
Joined:  2008-12-16
 

TO ALL WHICH DON’T WORKS IT ON XAMPP
you must enable the extension in directory ...xampp\apache\bin
in file php.ini
this must be removed ;
extension=php_curl.dll
and it must work

 
Magento Community Magento Community
Magento Community
Magento Community
 
mrobo
Jr. Member
 
Total Posts:  5
Joined:  2008-12-16
 

TO ALL WHICH DON’T WORKS IT ON XAMPP
you must enable the extension in directory ...xampp\apache\bin
in file php.ini
this must be removed ;
extension=php_curl.dll
and it must work
cheese

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 4