Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Multi site : impossible d’accéder à un site
 
fabien_dagobear
Jr. Member
 
Total Posts:  1
Joined:  2013-07-20
 

Bonjour à tous,

Dans mon magento j’ai configuré 3 websites
- website1 avec 2 vues (anglais + français)
- website2 avec 2 vues (anglais + français)
- website3 avec 1 vue (anglais)

Ces 3 websites ont des noms de domaines différents.

Je n’ai strictement aucun problème pour accéder aux 2 premiers websites en revanche je n’arrive pas à accéder au 3è.
Lorsque je tape l’url de mon website3 j’ai un fichier qui se télécharge. Ce fichier est à priori un fichier de conf dans lequel j’ai :

* @category   Mage
 
* @package    Mage
 
* @copyright  Copyright (c2008 Irubin Consulting IncDBA Varien (http://www.varien.com)
 
* @license    http://opensource.org/licenses/osl-3.0.php  Open Software License (OSL 3.0)
 
*/

if (
version_compare(phpversion(), \\\'5.2.0\\\'\\\'<\\\')===true{
    
echo  \\\'<div style=\\\"font:12px/1.35em arial, helvetica, sans-serif;\\\"><div style=\\\"margin:0 0 25px 0; border-bottom:1px solid #ccc;\\\"><h3 style=\\\"margin:0; font-size:1.7em; font-weight:normal; text-transform:none; text-align:left; color:#2f2f2f;\\\">Whoops, it looks like you have an invalid PHP version.</h3></div><p>Magento supports PHP 5.2.0 or newer. <a href=\\\"http://www.magentocommerce.com/install\\\" target=\\\"\\\">Find out</a> how to install</a> Magento using PHP-CGI as a work-around.</p></div>\\\';
    exit;
}

/**
 * Error reporting
 */
error_reporting(E_ALL E_STRICT);

/**
 * Compilation includes configuration file
 */
$compilerConfig \\\'includes/config.php\\\';
if (
file_exists($compilerConfig)) {
    
include $compilerConfig;
}

$mageFilename 
\\\'[i][u][b]chemin_accès_fichier_Mage.php[/b][/u][/i]\\\';
$maintenanceFile \\\'maintenance.flag\\\';

if (!
file_exists($mageFilename)) {
    
if (is_dir(\\\'downloader\\\')) {
        header
(\\\"Location: downloader\\\");
    
else {
        
echo $mageFilename.\\\" was not found\\\";
    
}
    
exit;
}

if (file_exists($maintenanceFile)) {
    
include_once dirname(__FILE__) . \\\'/errors/503.php\\\';
    exit;
}

require_once $mageFilename;

#Varien_Profiler::enable();

if (isset($_SERVER[\\\'MAGE_IS_DEVELOPER_MODE\\\'])) {
    Mage
::setIsDeveloperMode(true);
}

#ini_set(\\\'display_errors\\\', 1);

umask(0);

/* Store or website code */
$mageRunCode = isset($_SERVER[\\\'MAGE_RUN_CODE\\\']) ? $_SERVER[\\\'MAGE_RUN_CODE\\\'\\\'[i][u][b]code_de_ma_vue_magasin[/b][/u][/i]\\\';

/* Run store or run website */
$mageRunType = isset($_SERVER[\\\'MAGE_RUN_TYPE\\\']) ? $_SERVER[\\\'MAGE_RUN_TYPE\\\'\\\'store\\\';

Mage::run($mageRunCode$mageRunType);

Quelqu’un aurait-il une idée de ce que je dois faire pour pouvoir accéder normalement à mon site ?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top