Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Import Successful - but with a few problems
 
v2uk
Member
 
Total Posts:  64
Joined:  2008-03-23
 

Hi Guys,
I’ve managed to import a few products by creating a default product, then exporting that csv, then copy/pasting the data into the right columns.

I’ve come up with a few snags through:

1) When importing the products, they appear in the admin ready to be placed in a category, however, when placing them in a category I have to go into the product and then save it. (Granted, the first product i did this on was missing the weight and short description, so not sure if it was these 2 things stopping it from showing on the front end, anyone else been successful?)

2) When using “http:///www.foo.com/image.jpg” etc for ‘small_image / ‘thumbnail’ / ‘image’ - When it’s imported magento seems to drop these columns, I’m assuming it does a check to see if http:// exists on it, if not then disregard it? or something along these lines.

Is there anyway I can use external images? or does anyone know of any program I could download to fetch hundreds of images from the server, and perhaps some php code to then run through the directory? the images don’t follow suite of any refferencing as there stored across a couple of servers, so would need to use the current sku of the csv + these image columns to download > rename > store > parse back into another csv? But I have no idea how to do this.

3) Categorising, is there any decent / reliable method of categorising here?, the products I have each have a associated category ‘name’ with them, magento seems to use a series of numbers to disctate the category it’s held within, I can live with doing this manually to be honest if i can attach another attribute to show in the admin category products area to show an additional attribute as a fast reference.

4) Additional attributes, manufactor, colour - How does adding new attributes here work? and how do I create a new attribute to be used? can anyone explain or point me in the right direction of what each field means?

Cheers guys!

 
Magento Community Magento Community
Magento Community
Magento Community
 
v2uk
Member
 
Total Posts:  64
Joined:  2008-03-23
 

Regarding the images, thumb / image / small image:

I can assign 2 references in the url path and the csv that i can assign to, one being the sku and the other being merchant.

So at the moment I have:

| merchant | sku | image | small_image | thumb_image |
| 1234 | 54 | http://images.domain.com/image/54/1234.jpg | http://images.domain.com/images/54/1234.jpg | http://images.domain.com/thumb/54/1234.jpg |
| 5678 | 54 | http://images.domain.com/image/54/5678.jpg | http://images.domain.com/images/54/5678.jpg | http://images.domain.com/thumb/54/5678.jpg |
| 4321 | 40 | http://images.domain.com/image/54/4321.jpg | http://images.domain.com/images/40/4321.jpg | http://images.domain.com/thumb/40/4321.jpg |

etc

 
Magento Community Magento Community
Magento Community
Magento Community
 
v2uk
Member
 
Total Posts:  64
Joined:  2008-03-23
 

Anyone able to shed any light on this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
WildWire
Jr. Member
 
Total Posts:  19
Joined:  2008-03-31
 

1)

When importing the products, they appear in the admin ready to be placed in a category, however, when placing them in a category I have to go into the product and then save it. (Granted, the first product i did this on was missing the weight and short description, so not sure if it was these 2 things stopping it from showing on the front end, anyone else been successful?)

Well on import from CSV, I was having a similar problem.  If you change the store column data from ‘admin’ to ‘default’ it will assign correctly to the store.

2)

When using “http:///www.foo.com/image.jpg” etc for ‘small_image / ‘thumbnail’ / ‘image’ - When it’s imported magento seems to drop these columns, I’m assuming it does a check to see if http:// exists on it, if not then disregard it? or something along these lines.

For me, all image importing is broken via csv in Magento 1.0, worked fine before, so still working on it. 

Is there anyway I can use external images? or does anyone know of any program I could download to fetch hundreds of images from the server?

I’m not sure if magento will let you use external images, but if you have the urls, it would be very easy to write a script with wget.  simply add wget.exe to the beginning of each image url, and save to a batch file.

4)

Additional attributes, manufactor, colour - How does adding new attributes here work? and how do I create a new attribute to be used? can anyone explain or point me in the right direction of what each field means?

I was able to get Manufacturer to import by adding all of my desired Manufacturers under the Manufacturer Attribute as options.  Until I manually added them in, they would not import.

I am still learning it all myself, so I hope this helps point you in the right direction.

 
Magento Community Magento Community
Magento Community
Magento Community
 
v2uk
Member
 
Total Posts:  64
Joined:  2008-03-23
 

there any way to get around magento not allowing full url’s to be parsed for the images?

that is going to be my main time consuming aspect of this i think at themoment.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JayBird
Jr. Member
 
Total Posts:  2
Joined:  2007-09-30
 

I am also keeping up with this thread, I would like to import around 13,000 product images… not all of them will be enabled, since the stock level varies on these daily/ weekly… I am also having problems getting pics to show…

Jay

 
Magento Community Magento Community
Magento Community
Magento Community
 
radders
Sr. Member
 
Total Posts:  162
Joined:  2008-03-23
 

’status’, ‘visibility’, and ‘is_in_stock’ are all being ignored. Everything else (apart from the images of course) works fine. Categories no problem.

Any thoughts?

 
Magento Community Magento Community
Magento Community
Magento Community
 
radders
Sr. Member
 
Total Posts:  162
Joined:  2008-03-23
 

Whoops - thought they were boolean. Now it just leaves the images to fix.....................

 
Magento Community Magento Community
Magento Community
Magento Community
 
v2uk
Member
 
Total Posts:  64
Joined:  2008-03-23
 

feasable option to upload all images as “/foo/bar/bleh.jpg” so that magento accepts the values, then doing a sql update to insert / replace all “/foo/bar/bleh.jpg” to “http://foo.bleh.com/foo/bar/bleh.jpg” etc in a csv where id = foo, will this force it to accept external image pathings?

Or will magento screw this up and revert it back / not show the images?

 
Magento Community Magento Community
Magento Community
Magento Community
 
mayerwin
Sr. Member
 
Avatar
Total Posts:  182
Joined:  2008-01-15
France
 

I am also interested in solving this, it would be much simpler than copying the images to my server. Keep me updated if you find something.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mayerwin
Sr. Member
 
Avatar
Total Posts:  182
Joined:  2008-01-15
France
 

I finally posted a solution to import external images here: http://www.magentocommerce.com/boards/viewthread/6947/.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top