Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

E-Mail Templates für System Mails fehlerhaft
 
Klimek
Sr. Member
 
Avatar
Total Posts:  83
Joined:  2008-09-01
Essen
 

Meine System Mails für bspw. Bestellungen sind was die Codierung geht fehlerhaft, zusätzlich werden diese aber auch als Anhang verschickt, was folgt ist sie landen zu 90% im Spam ...

Wo kann man die Codierung und die Art des Versandsändern?

Die Nachrichten sollen als HTML ohne Anhang versendet werden. Eine Leere Nachricht mit HTML als Anhang ist jedenfalls verdammt schlecht.

Danke wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
Klimek
Sr. Member
 
Avatar
Total Posts:  83
Joined:  2008-09-01
Essen
 

Ich hab zwar mitlerweile die Umlaute durch ü und Co. im Template ersetzt was sicherlich auch funktioniert, jedoch habe ich immer noch das Problem, dass Artikel im Shop Sonderzeichen aufweisen und das “€” Zeichen in der Bestellung auftaucht und nicht richtig dargestellt wird:

Beispiel:

Artikel Artikelnummer Stk.  Zwischensumme
Herren-Windbreaker DTM

Größe
M

31308020 1 109,90 €
Zwischensumme 92,35 €
Versand & Bearbeitung 3,28 €
Steuern 18,17 €
Gesamtsumme 113,80 €

-----------------

Und auch kommt weiterhin das HTML File als Anhang statt direkt dargestellt zu werden ...

Was ich zur Codierung noch versucht hatte war folgendes:

<?xml version="1.0" encoding="iso-8859-1"?><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<
html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<
head>
    <
meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
</
head>

Leider hat auch dies in den HTML Templates fürs Mailing garnichts bewirkt ... hat denn keine ähnliche Probleme?!

 
Magento Community Magento Community
Magento Community
Magento Community
 
X-ander
Jr. Member
 
Total Posts:  11
Joined:  2008-12-17
Heilbad Heiligenstadt
 

Hi Klimek,

ich habe auch selbiges Problem nach Aufspielung von market_ready.
Die versendeten Emails haben keinen Doctype. Es scheint als ob nur der Code des Templates und nicht das Gerüst drumherum abgesendet wird.

Hast du hierzu schon eine Lösung gefunden? Oder jemand anderes ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
informixx
Jr. Member
 
Total Posts:  27
Joined:  2009-08-24
 

Ich kann die geschilderten Probleme die durch das market Ready Modul von symmetrics auftreten nur bestätigen!
Das Modul ist leider mit der heissen Nadel gestrickt worden und in großen Teilen einfach nur ganz grosser Mist… :-(
Hier sollten die Jungs mal ganz schnell ein Releaseupdate für das Modul nachschieben, aber offensichtlich reicht es denen sich darüber in Deutschland - in Verbindung mit trusted Shops - erst mal einen Namen gemacht zu haben… wink

Hier sind dann manuelle Anpassungen erforderlich bzw. die erforderlichen Änderungen wieder zurückzunehmen. Ich kann nur jedem empfehlen das Market Ready Modul gar nicht erst zu installieren! Das einzige was dieses Modul letzten Endes an Verwertbarem mitbringt ist die Ampelanzeige am Warenbestand im Frontend…

Mich würde vielmehr interessieren welche alternativen Wege Ihr bei der Kommunikation beschreitet…

so long, informixx

 
Magento Community Magento Community
Magento Community
Magento Community
 
Klimek
Sr. Member
 
Avatar
Total Posts:  83
Joined:  2008-09-01
Essen
 

Mit fehlenden Doctypes hatte ich glaub ich keine Probleme, lediglich die Codierung.

Das erwähnte Paket wurde zu dem Zeitpunkt auch noch nicht released, somit habe ich damit bisher keine Erfahrungen gemacht.

Das die Mails als Anhang ankamen, lag bzw. liegt wohl mehr an unserem Server intern, bei anderen Diensten bzw. Servern kamen die Mails an wie gewünscht.

Ansonsten möchte ich einfach mal behaupten, dass die Mails auch ohne Doctype funktionieren sollten?!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Vogl
Member
 
Total Posts:  34
Joined:  2009-11-24
 

Hallo, ich denke, ich kann zumindest Euer Problem mit der fehlerhaften Codierung lösen.
Hatte dies ebenfalls und wie folgt gelöst.

Sicherlich habt Ihr schon sämtliche E-Mail Vorlagen vorbereitet.

1. System - Transaktions-E-Mails -
hier die Vorlage auswählen, Quellcode kopieren und in einem Editor einfügen.

2. folgenden Code vor Eurem Quellcode im Editor einfügen

<!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8” />

3. kompletten Quellcode kopieren und wieder in Eurem Admin-Bereich einfügen.

So, jetzt sollten alle Hieroglyphen ordentlich lesbar sein.

Mit der leeren E-Mail inklusive dem Anhang habe ich auch noch zu kämpfen.

Vielleicht kann mir hier aber jemand von Euch helfen, falls Ihr das Problem schon gelöst habt.

Gruß Daniel

 
Magento Community Magento Community
Magento Community
Magento Community
 
sieppl
Jr. Member
 
Total Posts:  12
Joined:  2009-04-14
 

Hi,

da ich das Problem (leere E-Mail mit Anhang) auch habe (Magento 1.3.2.4 inkl. Market Ready 0.1.7), wollte ich Fragen ob jemand eine Lösung gefunden hat?
Es scheint, dass einige ältere Outlook Versionen ein Problem mit den E-Mails haben.

Danke und Gruß
Sebastian

 
Magento Community Magento Community
Magento Community
Magento Community
 
danillo
Member
 
Total Posts:  53
Joined:  2007-09-20
 

Vielleicht kann das helfen: http://www.magentocommerce.com/boards/viewthread/25075/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top