Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

How can I install Magento at localhost? 
 
datspa2204
Jr. Member
 
Total Posts:  3
Joined:  2013-05-31
 

I want to install Magento at localhost with wamp server?
Plz show me your experience!

 
Magento Community Magento Community
Magento Community
Magento Community
 
mikejswan
Jr. Member
 
Total Posts:  9
Joined:  2013-04-05
Rochester, NY
 

check version of PHP, which you will use. Magento not work with PHP 5.3 (for XAMPP, use XAMPP for Windows Version 1.7.1 ) Magento 1.4.1.1 works fine on WAMP v2.0 running PHP 5.3.0

Note: On WAMP v2.x, modules can be enabled and disabled through the Aestan Tray Menu by pointing to PHP→PHP Extenstions then clicking the appropriate extension. Magento 1.7 does not work with WAMP 2.2. You may use WAMP 2.1.

1)
Download and Install (place magento files as referenced in installation instructions)

2) Setup Database using phpmyadmin (goto: http://localhost , there will be a link on the left to goto phpmyadmin)

3) Edit apache/conf/httpd.conf change line

#LoadModule rewrite_module modules/mod_rewrite.so

to

LoadModule rewrite_module modules/mod_rewrite.so

(just remove the # )

4) Edit apache/bin/php.ini and php/php.ini (same changes on both files - note, as of XAMPP 1.7.1, you will only have to change php/php.ini) change lines (the first change is not necessary on xampp):

;extension=php_mcrypt.dll

to

extension=php_mcrypt.dll

and changes lines:

;extension=php_curl.dll

to

extension=php_curl.dll

(just remove the ; )

4a) On WAMP you must also change the following line in apache2/bin/php.ini and php/php.ini changes lines:

;extension=php_pdo_mysql.dll

to

extension=php_pdo_mysql.dll

(just remove the ; )

In addition to php_pdo_mysql.dll, you may also need to make sure you are loading:

extension=php_pdo.dll

5) There is a bug in Windows’ php_pdo_mysql implementation. It is possibly related to this bug documented here: http://bugs.php.net/bug.php?id=39759 and here: http://bugs.php.net/bug.php?id=39858 . Workarounds could be:

using ODBC (will be described how to apply in Magento later)
download http://www.nolimitclubbing.com/lib_php/php_pdo_mysql.dll (mirror for the file mentioned in bug comments) and add this file to your phpext directory Warning: broken link.
Wampp has a version of libmysql.dll that works fine. Download here http://www.apachefriends.org/en/xampp-windows.html If you prefer Xampp over Wampp, simply copy the good libmysql.dll from your wampp installation into your xamppapachebin directory.

Here is another link to the libmysql.dll file: http://www.mediafire.com/download.php?yr4mjzwwzzd

Note above file is linked by a community member, FrenchToast and the current download above is hosted by Xavier ETCHEBER. While there has been no problems with this file it has not been fully verified.

6) Restart all servers

7) Goto: http://localhost/magento/install (replace the above “magento” with where your installation was extracted to)

8) On page 2 “Configuration” change database as needed and change Secure Connection to: (XAMPP actually supports SSL over port 443 - so this step is not needed if you want to test SSL)

Secure Hostlocalhost (could be different)
    
Secure Base Path: /magento/ (also could be different)
    
Secure Protocolhttp
    Secure Port
80

9) Continue with install, all should be good!

Magento requires itself to be installed on a host name with at least one period ‘.’ in it, therefore installing to http://localhost doesn’t work. (Having installed to //localhost, I was unable to get it running even after the following changes. In the end I had to reinstall using the new host name which then worked fine.)

If you can’t login to the administration panel after installation, that’s because there’s a cookie problem. Add these lines:

127.0.0.1        magento.localhost.com www.localhost.com

to:

C:/Windows/System32/drivers/etc/hosts (edit this file in notepad)

Then go to http://www.localhost.com/<folder>

NB: This was the key note (9) to allowing me to install the latest version of Magento on the latest version of XAMPP (13 July 2011). You will need to change the permission of the ‘hosts’ file in window to allow you to save. All the other changes had already been made in my version of XAMPP. Once you have made the change reinstall Magento using the downloader and the http://www.localhost.com/<folder>.

 
Magento Community Magento Community
Magento Community
Magento Community
 
zesttech
Member
 
Total Posts:  31
Joined:  2012-04-30
London, UK
 

Download WAMP Server: - For downloading WAMP server you need to go to http://www.wampserver.com. You can download the latest version of WAMP 2.0i along with installation details from this URL. After download you will receive a Set Up file. Just install and start the WAMP server.

Download Magento CE: - For downloading Magento CE you need to go to http://www.magentocommerce.com. From download section download the latest version of Magento CE in zip format. Extract the zip folder and copy the folder called “magento” to WAMP installation path ‘WWW’ folder.

Create Database for Magento: - To install Magento on your local machine you need to create one database. So just go to ‘PHPMyAdmin‘ and create a database e.g. ‘magentotest’.

Start installing Magento: – Now start WAMP localhost in your machine. In the ‘Projects’ section, you will see a folder called ‘magento’, just click on this project.’ Magento Installation Wizard’ will start. In the next step click on the ‘Continue’ button and enter localization settings. In the next phase enter proper configuration settings and click on ‘Continue’ button.

Appearance of Error: - At this point of time an error will appear ‘Maximum execution time of 30 seconds exceeded in ‘Installation path of WAMP/WWW/magento/lib/ZendDB/Statement/Pdo.php’

How to fix this error?

Well, this error can be fixed easily; Here we are providing the solution to fix this error within a short time.

Steps to fix this error:
1.Open WAMP Server menu->go to PHP-> select php.ini file
2.The file will be opened in a notepad.
3.Find the code ‘max_execution_time’. By default the value set is ‘60’. Change it with a higher value ‘1800’.
4.Find the code ‘max_input_time’. By default the value set is ‘30’. Again change it to ‘1800’.
5.Save php.ini file.

See the result after fixing the error: - Now you are all set to see the result of what you have done. So start viewing it like this:
1.Restart your WAMP services.
2.Open WAMP localhost
3.Click on the ‘magento’ folder
4.Magento Installation Wizard will appear. Click on the ‘Continue’ button.
5.Enter localization settings.
6.Enter configuration settings. Click on the ‘Continue’ button.
7.Now you will get the Admin setup section of Magento rather than the previous error.
8.Setup and save Magento Admin settings.
9.Get the Magento user panel on the URL http://localhost/magento/index.php and get the admin panel of Magento on the URL http://localhost/magento/index.php/admin.

 
Magento Community Magento Community
Magento Community
Magento Community
 
datspa2204
Jr. Member
 
Total Posts:  3
Joined:  2013-05-31
 

Thank all! I got it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MJes
Jr. Member
 
Total Posts:  5
Joined:  2013-03-20
 

This thread may help you

http://www.techigenius.com/install-magento-using-wamp-server/

 
Magento Community Magento Community
Magento Community
Magento Community
 
mariaperez1979
Jr. Member
 
Total Posts:  3
Joined:  2014-05-02
 

I’m trying to install a magento store within a directory wordpress listademorosos.net but I can not, anyone know where there’s an easy guide to a newbie, try localhost first, but do not get a new server install, the problem will server?

 
Magento Community Magento Community
Magento Community
Magento Community
 
FidoDC
Jr. Member
 
Total Posts:  21
Joined:  2010-12-20
 

you need checked ckeckbox Skip Base URL - somehow, under the input fields for the database

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top