Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento gets totally messed up when changing language
 
Roy Andre
Sr. Member
 
Avatar
Total Posts:  209
Joined:  2007-08-31
 

I installed the latest beta and found a setting in the Admin Configuration-panel where I could change the default language. I chose Norwegian here (although I perfectly know Magento hasnt been translated into Norwegian yet), but then everything like uhm.. crashed.. (see screenshot).

I think you should modify the code so that it always falls back to English if a language you have chosen doesn exist, or isnt fully translated (or not even display other languages than those who are installed).

PS: This wasnt actually an “Installer-problem”, although I wasnt sure where to address it. Its both a Bug-report and a warning for you all not to change the default langauge in Magento smile

Image Attachments
magento_norwegian.PNGmagento_norwegian2.PNG
 
Magento Community Magento Community
Magento Community
Magento Community
 
Roy Andre
Sr. Member
 
Avatar
Total Posts:  209
Joined:  2007-08-31
 

And by the way, this is how you fix it if you have screwed it up like I did.

1. Log on to the MySQL-database using ‘mysql’ in shell or PHPMyAdmin or whatever.

2. Navigate to the core_config_data table, which holds most of the settings in your Magento-setup

3. Find general/local/language and change it to ‘en’

4. Voilà grin

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top