Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Probleme module Cybermut / CIC
 
Emulsion
Jr. Member
 
Total Posts:  5
Joined:  2009-07-20
 

Bonjour,

Je finalise actuellement ma première boutique sous magento.

Après avoir bataillé avec les règles de TVA, je n’arrive pas à faire fonctionner le module Cybermut télécharger sur ce site.

J’ai rentré les différents paramètres (TPE, code boutique, fichier clé (non modifié)).

Lorsque j’essaye de réaliser un paiement en mode test j’ai en retour ce message :

Warning: pack() [function.pack]: Type H: illegal hex digit in /*********************/shop/app/code/local/Mage/Cybermut/Model/Payment.php on line 316
Trace:
#0 [internal function]: mageCoreErrorHandler(2, ‘pack() [_getKeyEncrypted()

Je pense qu’il y a une modification à faire sur le fichier key mais je ne sais pas laquelle.

Merci pour votre aide,

Thomas.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Emulsion
Jr. Member
 
Total Posts:  5
Joined:  2009-07-20
 

Personne qui a installé ce module ?

Une petite aide serait grandement apprécié.

 
Magento Community Magento Community
Magento Community
Magento Community
 
anthowid
Jr. Member
 
Total Posts:  15
Joined:  2009-01-12
 

Oui j’ai installé ce module et j’ai le même problème que toi avec la même erreur une fois la commande terminée.
J’ai donc contacter la banque qui m’a gentiment répondu que ce n’était pas leur problème et que c’était une erreur de programmation.
Je suis donc toujours bloqué ...
As-tu trouvé un solution à ton problème ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Emulsion
Jr. Member
 
Total Posts:  5
Joined:  2009-07-20
 

Oui, j’ai trouvé la solution, il suffit de télécharger la clé en version 2 et non pas en version 3 sur le site de la banque.

Ensuite il faut renommer le fichier et l’éditer pour ne laisser que la chaine de caractère de la première ligne (en retirant VERSION 1).

Ensuite cela fonctionne parfaitement en mode test et en mode production smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
anthowid
Jr. Member
 
Total Posts:  15
Joined:  2009-01-12
 

Nickel ça fonctionne.
Merci beaucoup.

 
Magento Community Magento Community
Magento Community
Magento Community
 
anthowid
Jr. Member
 
Total Posts:  15
Joined:  2009-01-12
 

Par contre les paiements fonctionnent bien mais apparemment j’ai un problème avec l’url de retour qui est :
http://www.monsite.fr/cybermut/payment/notify/

J’ai une erreur :
Notice: Undefined index:  MAC in /home/monsite/www/app/code/local/Mage/Cybermut/controllers/PaymentController.php on line 105

As-tu eu cette erreur aussi ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Emulsion
Jr. Member
 
Total Posts:  5
Joined:  2009-07-20
 

Oui, cela vient sans doute de la gestion des url par magento.

Essaye avec : http://www.monsite.fr/index.php/cybermut/payment/notify/

Si ce n’est pas ça je ne vois pas.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tutorial-project
Jr. Member
 
Total Posts:  8
Joined:  2009-08-20
 

Bonjour,

J’ai aussi ce problème, avez-vous réussi à résoudre le problème de l’url retour car je suis en phase de test et pour moi tout fonctionnait bien juste “test cgi 2 not ok” , j’avais donné comme url retour celle ci ou je recevais bien en tant que client les informations de commande et en tant qu’administrateur aussi je povais bien visualiser la commande mais la banque me dit que l’url renvoie vers un panier vide mais je trouve çà normal car il n’ont passé commande ni ajouter un prdt dans le panier et ne se sont pas connecté :

Savez qu’elle url donné en sachant que j’ai un répertoire ‘boutique’

j’ai essayé celle mentionnée avec le code la vue et sans sur le site mais elle me renvoie une erreur : Undefindex index

http://www.monsite.com/boutique/index.php/cybermut/payment/notify/

http://www.monsite.com/boutique/cybermut/payment/notify/

app/code/local/Mage/Cybermut/controllers/PaymentController.php on line 105

TOD,

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gregoire
Jr. Member
 
Total Posts:  15
Joined:  2009-05-13
 

Je dirai que c’est normal, tu dois envoyer à la page les parametres demandées.
Quand la banque va faire appel à la page, elle va faire passer les parametres comme MAC, retourPLUS, etc....
La, étant donné que tu ne les fournies pas dans ton test, ça t’affiche une erreur.

Essaye avec http://www.monsite.com/boutique/cybermut/payment/notify?MAC=test&retourPLUS;=test
et tu verras que l’erreur est différente.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Flopy69
Sr. Member
 
Avatar
Total Posts:  124
Joined:  2008-06-04
Lyon
 

Bonjour,

J’ai le même problème sur un site en prod, j’ai un 404 not found sur cette page : boutique/cybermut/payment/notify?MAC=test&retourPLUS;=test

et test cgi 2 not ok…

que faire ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Flopy69
Sr. Member
 
Avatar
Total Posts:  124
Joined:  2008-06-04
Lyon
 

bon donc pour information l’adresse doit inclure le code du magasin chez nous cétait :

http://www.monsite.com/boutique/french/cybermut/payment/notify

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top