Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
also getting Url “http://localhost:80/magento/” is not accessible
 
bobh
Member
 
Total Posts:  32
Joined:  2007-08-31
 

I have read all posts i think on it and gave rights to the magento folder and have all mods enabled that is required but can not figure it out. Anyone else have that same problem and figured it out ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
_
Sr. Member
 
Total Posts:  152
Joined:  2007-08-31
 

what does the function file_get_contents(’http://localhost:80/magento/’) return ? Error or something else ? If error you should check if this function isn/t blocked on your server. In my case it was smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
bobh
Member
 
Total Posts:  32
Joined:  2007-08-31
 

Where do i check that. Sorry a real newb when it comes to that. Dont even know how to bring up if it is blocked or not

 
Magento Community Magento Community
Magento Community
Magento Community
 
_
Sr. Member
 
Total Posts:  152
Joined:  2007-08-31
 

Simply create a php file :

<?php
file_get_contents(’http://localhost:80/magento/’);
?>

and check what it returns

 
Magento Community Magento Community
Magento Community
Magento Community
 
bobh
Member
 
Total Posts:  32
Joined:  2007-08-31
 

well prob did something wrong but created a test.php file with
<?php
file_get_contents(’http://localhost:80/magento/’);
?>
and all i got back was this Parse error: syntax error, unexpected ‘:’ in C:\wamp\www\magento\test.php on line 2

 
Magento Community Magento Community
Magento Community
Magento Community
 
bobh
Member
 
Total Posts:  32
Joined:  2007-08-31
 

any idea’s ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Phil
Member
 
Avatar
Total Posts:  50
Joined:  2007-08-31
Göttingen / Bad Oldesloe, GERMANY
 

no, just the same problem

 
Magento Community Magento Community
Magento Community
Magento Community
 
henriquemattos
Jr. Member
 
Avatar
Total Posts:  7
Joined:  2007-08-31
Niterói, Rio de Janeiro
 

Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.
Error 500

but the server isn’t overload at all. So how do I fix this CGI problem?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siddharth Menon
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2007-08-31
Mumbai
 

Yes I am facing the same problem tried everything thats posted on this site. It still says url not accessible.

bobh - 31 August 2007 11:45 AM

well prob did something wrong but created a test.php file with
<?php
file_get_contents(’http://localhost:80/magento/’);
?>
and all i got back was this Parse error: syntax error, unexpected ‘:’ in C:\wamp\www\magento\test.php on line 2

Even I tried this method and I get same error. Does that mean that function is disabled on my server ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
_
Sr. Member
 
Total Posts:  152
Joined:  2007-08-31
 

<?php
$url 
'http://localhost:80/magento/';
$checkRes file_get_contents($url);
echo 
$checkRes;
?>

try also this code. It is 100% correct.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siddharth Menon
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2007-08-31
Mumbai
 

Thanks just tried seems URL-File access is disabled on my host.

Warningfile_get_contents() [function.file-get-contents]URL file-access is disabled in the server configuration in /home/.mike/xxxx/xxxx.com/shop/test.php on line 3

Warning
file_get_contents(http://xxx.mysite.com:80/magento/) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /home/.mike/xxxxx/xxxxxx.com/shop/test.php on line 3

I can upload custom php.ini to my host could you suggest somthing ?  smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
_
Sr. Member
 
Total Posts:  152
Joined:  2007-08-31
 

Please check this : http://wiki.dreamhost.com/index.php/Allow_url_fopen

and maybe this http://209.85.135.104/search?q=cache:DH1r-EreoAAJ:php.net/filesystem+allow_url_fopen&hl;=pl&ct;=clnk&cd;=2&gl;=pl

How to change setting is described on this page:

http://209.85.135.104/search?q=cache:txFf5a8OlqYJ:bugs.php.net/15854+allow_url_fopen+php.ini&hl;=pl&ct;=clnk&cd;=1&gl;=pl

 
Magento Community Magento Community
Magento Community
Magento Community
 
Phil
Member
 
Avatar
Total Posts:  50
Joined:  2007-08-31
Göttingen / Bad Oldesloe, GERMANY
 

got this mesage:

Warningfile_get_contents(http://localhost:80/magento/) [function.file-get-contents]: failed to open stream: Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne nicht richtig reagiert hat, 
oder die hergestellte Verbindung war fehlerhaftda der verbundene Host nicht reagiert hatin C:\xampp\htdocs\magento\1.php on line 3

Fatal error
Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\magento\1.php on line 3

but this tell’s only that excecution time is too short. i don’t think this script really needs more than 60 seconds…

allow_url_fopen = on

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siddharth Menon
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2007-08-31
Mumbai
 

K finally ... I turned on
allow_url_fopen=on

and uploaded my php.ini

Now its working and installation complete.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rowan
Jr. Member
 
Total Posts:  8
Joined:  2007-08-31
Australia, QLD
 

I’m getting the same error.

Vista, PHP 5.2.4, Apache 2.2.4, MySQL 5.0.45.

allow_url_fopen = On

Url “http://localhost:80/magento/” is not accessible

 
Magento Community Magento Community
Magento Community
Magento Community
 
Phil
Member
 
Avatar
Total Posts:  50
Joined:  2007-08-31
Göttingen / Bad Oldesloe, GERMANY
 

any new solution?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2