Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

1and1 problems
 
SoapMedia
Member
 
Avatar
Total Posts:  32
Joined:  2008-03-28
 

I have a 1and1 VPS hosting account (I guess a lot of other people here do too) which is running 8.3 Plesk which as standard runs PHP version 5.0.4

Ive tried the PHP CGI workaround by enable lines 6 - 8 in the htaccess and uploaded the php-cgi file to the cgi bin but i just get the error
“Internal Server Error”

Im hoping someone with a 1and1 VPS account could point me in the right direction as to get magento up and running

 
Magento Community Magento Community
Magento Community
Magento Community
 
tunersedge
Jr. Member
 
Avatar
Total Posts:  16
Joined:  2008-01-29
 

We’re on 1&1;. You’re on the right track, but don’t use the php-cgi workaround. Your 1&1;account has php 5.0 ability. Find this code in your .htaccess file and make sure it is uncommented:

############################################
## this line is specific for 1and1 hosting

AddType x-mapp-php5 .php

Then re-comment the php-cgi workaround code.

Let me know if that works!

 
Magento Community Magento Community
Magento Community
Magento Community
 
SoapMedia
Member
 
Avatar
Total Posts:  32
Joined:  2008-03-28
 

Aaron & Tim,

thanks for the response. Ive tried that I still get the invalid php version.

are you on a VPS account or shared hosting?

My VPS is running Plesk Fedora Core 4 with Plesk (64 bit) I have a feeling that workaround only works for shared hosting accounts.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top