Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Product view and administration don’t work
 
biblatte
Jr. Member
 
Total Posts:  17
Joined:  2009-06-22
 

Hello,

i’m so despair because the magento product administration don’t work. i had installed the following featured product extention
http://www.magentocommerce.com/extension/671/featured-products-slideshow
but i didn’t see at this time that the extention isn’t compatible with my magento version 1.3.2.1! Since this extention installation the product administration in the backend and the product view
http://www.flywear.eu/magento/report/?id=638403214&s;=default
in the frontend don’t work anytime. what can i do?

this is the error message:

There has been an error processing your request.

Warning: include(Mage/Awfps/Model/Entity/Attribute/Backend/Boolean/Config.php) [function.include]: failed to open stream: No such file or directory in /var/www/vhosts/flywear.eu/httpdocs/magento/lib/Varien/Autoload.php on line 93
Trace:
#0 /var/www/vhosts/flywear.eu/httpdocs/magento/lib/Varien/Autoload.php(93): mageCoreErrorHandler(2, ‘include(Mage/Aw...’, ‘/var/www/vhosts...’, 93, Array)
#1 /var/www/vhosts/flywear.eu/httpdocs/magento/lib/Varien/Autoload.php(93): Varien_Autoload::autoload()
#2 [internal function]: Varien_Autoload->autoload(’Mage_Awfps_Mode...’)
#3 [internal function]: spl_autoload_call(’Mage_Awfps_Mode...’)
#4 /var/www/vhosts/flywear.eu/httpdocs/magento/app/code/core/Mage/Core/Model/Config.php(1084): class_exists(’Mage_Awfps_Mode...’)
#5 /var/www/vhosts/flywear.eu/httpdocs/magento/app/Mage.php(319): Mage_Core_Model_Config->getModelInstance(’awfps/entity_at...’, Array)
#6 /var/www/vhosts/flywear.eu/httpdocs/magento/app/code/core/Mage/Eav/Model/Entity/Attribute/Abstract.php(330): Mage::getModel(’awfps/entity_at...’)
#7 /var/www/vhosts/flywear.eu/httpdocs/magento/app/code/core/Mage/Eav/Model/Entity/Abstract.php(575): Mage_Eav_Model_Entity_Attribute_Abstract->getBackend()
#8 /var/www/vhosts/flywear.eu/httpdocs/magento/app/code/core/Mage/Eav/Model/Entity/Abstract.php(1289): Mage_Eav_Model_Entity_Abstract->walkAttributes(’backend/afterLo...’, Array)
#9 /var/www/vhosts/flywear.eu/httpdocs/magento/app/code/core/Mage/Eav/Model/Entity/Abstract.php(834): Mage_Eav_Model_Entity_Abstract->_afterLoad(Object(Mage_Catalog_Model_Product))
#10 /var/www/vhosts/flywear.eu/httpdocs/magento/app/code/core/Mage/Core/Model/Abstract.php(216): Mage_Eav_Model_Entity_Abstract->load(Object(Mage_Catalog_Model_Product), 5, NULL)
#11 /var/www/vhosts/flywear.eu/httpdocs/magento/app/code/core/Mage/Catalog/controllers/ProductController.php(52): Mage_Core_Model_Abstract->load(5)
#12 /var/www/vhosts/flywear.eu/httpdocs/magento/app/code/core/Mage/Catalog/controllers/ProductController.php(138): Mage_Catalog_ProductController->_initProduct()
#13 /var/www/vhosts/flywear.eu/httpdocs/magento/app/code/core/Mage/Core/Controller/Varien/Action.php(376): Mage_Catalog_ProductController->viewAction()
#14 /var/www/vhosts/flywear.eu/httpdocs/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(248): Mage_Core_Controller_Varien_Action->dispatch(’view’)
#15 /var/www/vhosts/flywear.eu/httpdocs/magento/app/code/core/Mage/Core/Controller/Varien/Front.php(158): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#16 /var/www/vhosts/flywear.eu/httpdocs/magento/app/Mage.php(459): Mage_Core_Controller_Varien_Front->dispatch()
#17 /var/www/vhosts/flywear.eu/httpdocs/magento/index.php(65): Mage::run()
#18 {main}

thanks for your help

 
Magento Community Magento Community
Magento Community
Magento Community
 
ckosny
Guru
 
Total Posts:  349
Joined:  2009-02-28
Luxembourg
 

Have a look at the uninstall section in the overview for this extension - they mention this error there explicitly.

First, launch uninstall procedure from the MagentoConnect section of your admin panel, this will clean the files.

Since Magento does not support uninstall handlers for modules, you need to run the following SQL on your database manually:

DELETE FROM eav_attribute WHERE attribute_code = ‘aw_fps_available’;
DELETE FROM core_resource WHERE code=’awfps_setup’;

Unless you do so you would receive
“Error: Warning: include(Mage\Awfps\Model\Entity\Attribute\Backend\Boolean\Config.php) “
in the admin panel.

Also, do not forget to remove the HTML block from all places where you inserted it.
Unless you do so, you would receive an error on all pages of your shop that have the block inserted.

So try to uninstall the module as described here - hopefully this fixes the problem.

Good luck

Claudia

 
Magento Community Magento Community
Magento Community
Magento Community
 
biblatte
Jr. Member
 
Total Posts:  17
Joined:  2009-06-22
 

Hello Claudia,

thank you very much, it works beautiful now!!!

best regards
biblatte

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top