Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Fatal Error when editing a product
 
redegifts
Member
 
Total Posts:  41
Joined:  2007-12-04
 

Received the following FATAL ERROR when trying to edit a product created from the sample data

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1966080 bytes) in /home/******/public_html/magento/lib/Zend/Date.php on line 2554

 
Magento Community Magento Community
Magento Community
Magento Community
 
TwelveHorses
Jr. Member
 
Total Posts:  1
Joined:  2007-09-04
 

We are also having this same issue on a product we added ourselves.

Edit: We are also unable to add new products now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ifoundthetao
Jr. Member
 
Total Posts:  10
Joined:  2008-01-14
Elgin, IL
 

Any resolution with this?  What host are you using?  I was running Magento under hostgator and I had this error too, along with the same symptoms are you were experiencing.

When I contacted their support they basically said, “Tough luck.” :( I cried a little.

 
Magento Community Magento Community
Magento Community
Magento Community
 
alistek
Sr. Member
 
Total Posts:  293
Joined:  2008-04-02
Normal, IL
 

Magento requirements are for 64mb allocated to php.ini.  What are your host settings, I use hostmonster currently as a test platform and had to get them to up the limit.

-Adam

 
Magento Community Magento Community
Magento Community
Magento Community
 
BuyDigital
Member
 
Total Posts:  31
Joined:  2008-04-15
 

I just had this same issue while trying to install Magento at FastNext

a quick google search gave me this:
http://www.tech-recipes.com/php_programming_tips777.html

but i dont know what part of the script to add it to.

 
Magento Community Magento Community
Magento Community
Magento Community
 
redegifts
Member
 
Total Posts:  41
Joined:  2007-12-04
 

SOLUTION:

Seems that I found the solution.  By ENABLING all in Cache Management, I no longer received this message.  I just unchecked “Layouts” and I believe this will allow layouts to take effect.

Russ

 
Magento Community Magento Community
Magento Community
Magento Community
 
FetchDesigns
Sr. Member
 
Avatar
Total Posts:  124
Joined:  2008-04-11
Chicago, IL
 

Just FYI… I had this same problem (on Hostmonster as well) and tried this solution, but it didn’t fix my problem.  I talked with Hostmonster and they suggested I change from FastCGI to a single php.ini.  I did and gave it about 10-15 minutes to “simmer” and it started working again.

Hope this helps someone!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top