Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 5
Skip import row, required field “store” not defined
 
redegifts
Member
 
Total Posts:  41
Joined:  2007-12-04
 

Trying to import a basic .csv file with only the following fields

store, sku, name, price, qty

I get the following output when running the profile:

Skip import row, required field “store” not defined

I also get this if I don’t include a row “store”

I simply cannot figure out how to import products.  This is on release 1.0

 
Magento Community Magento Community
Magento Community
Magento Community
 
cyril
Jr. Member
 
Total Posts:  1
Joined:  2007-09-07
 

Hi all,

I have the same error :-(

REgards,
Cyril

 
Magento Community Magento Community
Magento Community
Magento Community
 
radders
Sr. Member
 
Total Posts:  162
Joined:  2008-03-23
 

Try using admin as the entry under the column store. Alternatively (and better) add a product and export it to see the file format should be.

 
Magento Community Magento Community
Magento Community
Magento Community
 
cibernoid
Sr. Member
 
Avatar
Total Posts:  208
Joined:  2008-02-12
 

Same error here. You cannot add products to a default store but you have to create a column in the csv file. Rather annoying I must say smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
redegifts
Member
 
Total Posts:  41
Joined:  2007-12-04
 

if i export the data, and then try to import the same file that was exported (by keeping only one column for a test and renaming some fields), I receive the same error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
iguru
Guru
 
Avatar
Total Posts:  331
Joined:  2007-11-01
Děčín, Czech Republic
 

hm, me to hmmm

 
Magento Community Magento Community
Magento Community
Magento Community
 
Max_Schreck
Jr. Member
 
Total Posts:  8
Joined:  2008-02-28
Czech Republic, Decin
 
redegifts - 31 March 2008 11:11 AM

Trying to import a basic .csv file with only the following fields

store, sku, name, price, qty

I get the following output when running the profile:

Skip import row, required field “store” not defined

I also get this if I don’t include a row “store”

I simply cannot figure out how to import products.  This is on release 1.0

Be sure the .csv file is in UTF-8.

 
Magento Community Magento Community
Magento Community
Magento Community
 
redegifts
Member
 
Total Posts:  41
Joined:  2007-12-04
 

still the same result

 
Magento Community Magento Community
Magento Community
Magento Community
 
Alexis O. Rodriguez
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2008-03-27
 

Houston, We’ve Got a Problem… smile

I’m having same issue.. but curious.. if i use a store=field on a column, can not import but says:

Skip import row, required field “XXXX” not defined and xxx = row value… !!!

I tried with xsl, different cvs, different field mapping, with and without order.. etc.. :(

Still no results…

 
Magento Community Magento Community
Magento Community
Magento Community
 
martinschm
Member
 
Total Posts:  56
Joined:  2008-03-03
 

Hi,

same here.
Guess its a bug.

cu
Martin

 
Magento Community Magento Community
Magento Community
Magento Community
 
winans_fred
Sr. Member
 
Total Posts:  83
Joined:  2007-09-06
 

Hi Guys

I’m working on debugging this right now.  Something with the the import process isn’t jiving.  I’ll keep you posted.

Fred

 
Magento Community Magento Community
Magento Community
Magento Community
 
winans_fred
Sr. Member
 
Total Posts:  83
Joined:  2007-09-06
 

Ok guys, I’ve found the problem.  Moshe and the gang is aware of it as well, but here is what is happening…

mapping fields not in order from left to right is not supported in import.  So, if I map column1, column4, column8, etc. it ignores that.  It looks at the value for SKU (second attribute i define in mapping) while trying to store to “type” which is mapped to column 2

I’ll try and fix this myself and keep you all posted.  It will be fixed in the next minor release, however, if you all are like me, you can’t wait wink

UPDATE ***SOLUTION***

Note: BE SURE TO CHECK THEM after they import! smile

I have now successfully imported my products, but here is how

- Make sure that the fields in your import file fall in the same order that the attributes you are mapping do in the Field Mapping List.  You don’t have to map every attribute, just the ones you want.  Then, make sure your import file fields fall in the same left-right order.

To ensure success, map the fields instead of using field names that are identical to the attributes.  I haven’t tested this.  You can if you want! smile

Also, make a test product that uses all the attributes you need and then export it.  Use this as the basis for your field values.  I was encoding things for the database, but the export showed a lot of text fields being used versus their integer value equivalents.

HTH!

Fred

 
Magento Community Magento Community
Magento Community
Magento Community
 
WildWire
Jr. Member
 
Total Posts:  19
Joined:  2008-03-31
 

You could also try setting the store column data to default ..  that should import it into your default store : )

 
Magento Community Magento Community
Magento Community
Magento Community
 
winans_fred
Sr. Member
 
Total Posts:  83
Joined:  2007-09-06
 

that feature does indeed work, but it doesn’t solve the larger problem (the bug).  Great input just the same, thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
cibernoid
Sr. Member
 
Avatar
Total Posts:  208
Joined:  2008-02-12
 

Thanks for the tips, dsgnfred. I still get the “field store not defined” error, though. :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
cibernoid
Sr. Member
 
Avatar
Total Posts:  208
Joined:  2008-02-12
 

Somehow I manage to get it working, though.
Still I cannot create a custom profile, so I’ve used one of those default profiles embedded within Magento 1.0 (called “Import all products).
Now I can import items and images correctly, but the variable “store”, setted ad “admin” isn’t recognized yet and I have to edit each file manually after import in order to assign it to specific store.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 5