Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

How do I “turn on” the secure connection, after it’s already installed? 
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

I just signed up for an SSL, but now I need to tell Magento to use it, the HTTPS protocol and the correct port. How do I do this, now that Magento is already installed?

I changed the settings in Admin > System > Configuration > Web to Use Secure URLs in Frontend and Use Secure URLs in Admin, but it doesn’t seem to change anything on my site, even after refreshing the cache.

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
golles
Sr. Member
 
Total Posts:  257
Joined:  2008-01-15
 

I am just about to try the same thing (note: have not tried as yet) - but I found this thread:

http://www.magentocommerce.com/boards/viewthread/4952/

Hope this helps

 
Magento Community Magento Community
Magento Community
Magento Community
 
Danielc1234
Sr. Member
 
Avatar
Total Posts:  175
Joined:  2008-01-09
Miami, FL - United States
 

Need the same. Front end is not switching into https mode at any point. Would be nice to have it go into secure mode once you hit the checkout process.
Any one have an answer?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

@Danielc
Did you read the post that golles pointed out to?
http://www.magentocommerce.com/boards/viewthread/4952/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Danielc1234
Sr. Member
 
Avatar
Total Posts:  175
Joined:  2008-01-09
Miami, FL - United States
 

Yes..I have enabled them on the admin side...its just when on the front end shopping, it never goes into the https secure mode.
Any ideas?
Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

Please show a screen shot of that Admin section
Make sure that you have in the Secure section base URL as your site URL and it includes httpS://www.your_domain

 
Magento Community Magento Community
Magento Community
Magento Community
 
Danielc1234
Sr. Member
 
Avatar
Total Posts:  175
Joined:  2008-01-09
Miami, FL - United States
 

Here is my admin page....I just left the defaults because it looks like it is calling the proper url. Not 100% sure though.
Thanks for your help.
Daniel

Image Attachments
securepage.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Danielc1234
Sr. Member
 
Avatar
Total Posts:  175
Joined:  2008-01-09
Miami, FL - United States
 

@Lior
Any ideas on this?
Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

@Danielc1234

Replace {{base_url}} in the Secure > Base URL section with your domain
Make sure that it is https://www.yourdomain/
Make sure that you have / at the end of the URL

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top