Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
Redirecionamento PagSeguro não funciona! 
 
Roberto Acioli
Jr. Member
 
Avatar
Total Posts:  22
Joined:  2010-02-01
Olinda, PE
 

Bruno,

Depois da última atualização que fiz, fiquei com problemas no meu backend. Agora quando tento acessar pedidos, o erro abaixo é exibido:

Exception printing is disabled by default for security reasons.
Error log record number: 879008141

Você poderia me confirmar quais arquivos você substituiu? Foram apenas os arquivo abaixo?

.../app/code/core/Mage/Sales/Model/Mysql4/Order/Address/Collection.php
.../app/code/core/Mage/Sales/Model/Mysql4/Order/Status/History.php
.../app/code/core/Mage/Sales/Model/Mysql4/Order/Status/History/Collection.php

Desde já agradeço!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bruno Assarisse
Sr. Member
 
Avatar
Total Posts:  119
Joined:  2009-09-13
São Paulo - Brasil
 

Desculpe não responder, Roberto, é que não apareceu sua mensagem pela visualização dos tópicos =/

Bom, o que eu fiz foi substituir tudo mesmo, pois vi relatos de que havia mais de 10 arquivos incorretos. Acho que se você substituir apenas a pasta /app/code/core/Mage/Sales dará certo, mas não posso garantir.
Além disso, segundo o pessoal da Varien, os pacotes no PEAR foram corrigidos, então se você reinstalar o magento-core/Mage_Core_Modules pelo Downloader, pode ser que fique OK.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Roberto Acioli
Jr. Member
 
Avatar
Total Posts:  22
Joined:  2010-02-01
Olinda, PE
 

Oi Bruno,

Obrigado novamente pela resposta!

Eu tentei reinstalar via PEAR, mas não consegui, pois a minha versão já consta como 1.4.1.1.
Com isso, baixei o TAR no site do magento e sobrescrevi toda a pasta .../app/code/core do meu site.

Parece que agora está tudo bem smile

Valeu!

 
Magento Community Magento Community
Magento Community
Magento Community
 
JonatasReis
Jr. Member
 
Total Posts:  5
Joined:  2011-06-16
 

Olá Bruno,
Estou usando seu módulo, em primeiro lugar, parabéns pela iniciativa, muito bom.
Estou com um problema, eu uso a loja versão 1.5.1.0
No inicio usei um módulo que baixei do próprio pagseguro, mas não enviava a confirmação do pedido para o usuário ao realizar a compra.
Já usando seu módulo apesar de não ser comartível com minha versão de loja, funcionou!
Só que na hora q sou redirecionado para a página do pagseguro aparece:

Ops! Houve um problema e não foi possível exibir a página

Quando eu usava o outro módulo o pagseguro carregava o pedido certinho, sabe como posso resolver esta questão?

Valew, abçs

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2