Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Error while trying to make a new theme
 
Muten
Jr. Member
 
Total Posts:  1
Joined:  2008-03-29
 

Hey I’m a real good designer and xhtml/css coder but I’ve never dealt with xml before and I can only read a decent amount of php.  So when it comes to script integration, I always get a little shaky - but I figured out WP recently, so i need Magento in my skillset.

I’ve gone thru the design guide and screencasts a few times over, and I understand quite a bit - however when i try to make my own theme from scratch I get a fatal error that says:

Fatal error: Call to a member function addLink() on a non-object in /hsphere/local/home/jparr887/421labs.com/pfz/mag2/app/code/core/Mage/Checkout/Block/Links.php on line 42

I’m pretty certain the error would go away if I could figure out how to write my page.xml.  My main goal is to at least get it so I can include all parts of my template (including css which i can’t figure out yet either), and then I’ll work on including the navs and other modules by studying the default templates. 

The design I’m trying to integrate with is very bare minimum, I won’t be using many of the modules at all - I only need one skeleton, I wish I could figure out the quickest way to start from scratch with this script because the design guide doesn’t really push me far enough in the right direction.

Can anybody help me troubleshoot this error & help me just get moving a little here? I could hook my lifesaver up with a design as thanks...

 
Magento Community Magento Community
Magento Community
Magento Community
 
c2h5oh
Jr. Member
 
Total Posts:  3
Joined:  2008-04-14
 

Same here - any solutions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aldo
Member
 
Total Posts:  47
Joined:  2008-02-18
 

Same here as well.
Any idea?

 
Magento Community Magento Community
Magento Community
Magento Community
 
bnwla
Jr. Member
 
Total Posts:  6
Joined:  2008-07-23
 

Hello,

Has anyone figured out any solution to this problem? I tried almost everything I could think of. Nothing seems to make this error go away…

 
Magento Community Magento Community
Magento Community
Magento Community
 
bnwla
Jr. Member
 
Total Posts:  6
Joined:  2008-07-23
 

I changed the namespace (a root directory of a module) for a new module to ‘Mage’ and it fixed the problem for me. Magento wiki page suggests that namespace should be unique, like the name of your organization, but that is obviously not a good convention for every case.

I think the problem is Magento tries to find functions within Mage classes and if the namespace is not Mage, it fails to find ones it needs. Be sure to change class name, method name, and etc. accordingly after you change the namespace.

Hope this helps someone like me. I just spent almost 10 hours on this. Ugh!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top