Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Zusätzliche Attribute in Suchergebnisen
 
GaMbIt_muc
Jr. Member
 
Total Posts:  4
Joined:  2009-02-05
 

Hallo Forum,

ich bin noch nicht besonders lang bei Magento, aber ich hab mich schon ein wenig durchgefressen und hänge nun an einer Geschichte fest.

Ich habe zwei zusätzliche Attribute angelegt und diese auch einem Attributset zugewiesen.
In der template/catalog/product/view.phtml habe ich dann diese Attribute aufgerufen.
$_product->getMyAttribute() funktioniert hier prima…

Was auf der Produktseite geht funktioniert aber leider nicht in der Listenansicht, catalog/product/list.phtml

Die Methode addAttribute() ist ja in der aktuellen Version implementiert, in der catalog.xml rufe ich auch die Methode auf..
<action method="addAttribute"><attribute>my_attribute</attribute></action>

Irgendwas habe ich vergessen.. oder irgendwo ist da der Wurm drin…
Selbst wenn ich einen varDump() auf das $_product ausführe bekomme ich die zugeordneten Attribute nicht ausgegeben…

Weiss jemand Hilfe?

Viele Grüße

GaMbIt

 
Magento Community Magento Community
Magento Community
Magento Community
 
GaMbIt_muc
Jr. Member
 
Total Posts:  4
Joined:  2009-02-05
 

Danke Leute… hat sich erledigt…

Ich bin mir sicher dass das jetzt nicht besonders rühmlich ist…

Ich habe in der Konfiguration vergessen die Option “Used in product listing” auf Ja zu stellen…

Asche auf mein Haupf wink

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top