Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
No input file specified
 
Gabrusch
Member
 
Avatar
Total Posts:  44
Joined:  2008-03-26
Wuerzburg, Germany
 

I have tried to setup Magento for at least 10 times now. Installation always works fine, but my frontend always gives me the error “No input file specified”

I use Dreamhost which means I have Php 5.2.x and I always tried it with the newest version of Magento (0.9.17740).

I used following hacks / modification I found throughout the web and in this community:
- modifying .htaccess in several ways
- using costum-made php5 as cgi-bin also with several options I found
- changing entries in php.ini
- using the “Dreamhost InstallMethod” described here

That’s all that comes to my mind right now. It all didn’t help.  I always tested the named changes directly and also did cross-checks by try some modifications together.

My domain is at http://magento.zechbauerdesign.de and the error occurs at http://magento.zechbauerdesign.de/index.php/
Here is my Php Info http://magento.zechbauerdesign.de/info.php

Any help is highly appreciated. One Magento is running I promise to support settting up a german translation of Magento (as my reward to the community)

Thank you

 
Magento Community Magento Community
Magento Community
Magento Community
 
msmirza
Jr. Member
 
Total Posts:  1
Joined:  2008-03-30
Lahore, Pakistan
 

I had a similar problem using Symfony on dreamhost. After some research, I figured out that the problem was caused by some bug in PHP 5.2.3. The issue is not visible in PHP 5.2.5.

If you install PHP 5.2.5 using the dreamhost installation instructions, and update your .htacess to use the PHP that you install, the “No input file specified” error would be resolved. Once you are done installing the new PHP, use phpinfo() to verify that dreamhost is indeed running the new PHP that you installed.

I used the alternative instructions from Charles Wiltgen at http://wiki.dreamhost.com/Installing_PHP5. The same page also has the changes that need to be made in .htacces.

Best of luck!
Mansoor
http://www.techtronix.biz

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gabrusch
Member
 
Avatar
Total Posts:  44
Joined:  2008-03-26
Wuerzburg, Germany
 

Thank you.

I will try it and post it here if it works

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gabrusch
Member
 
Avatar
Total Posts:  44
Joined:  2008-03-26
Wuerzburg, Germany
 

Amazing. It help. Thank you very much!

For all who encounter the same problem and use Dreamhost: Also follow the rules from the “Alternative Installation” Guidelines. Don’t forget to add ‘--with-pdo-mysql’ in the line of PHP-Features in the ‘php5-install.sh’ file as you will need PDO Mysql for Magento

 
Magento Community Magento Community
Magento Community
Magento Community
 
rareone
Jr. Member
 
Total Posts:  2
Joined:  2008-04-05
 

Hi, Gabrusch,

Can you tell me how u do it? i am using dreamhost too with php 5.2.3 , i tried to run the php5-install-prep.sh but it resulted in no such file/folder..

pls help.. thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gabrusch
Member
 
Avatar
Total Posts:  44
Joined:  2008-03-26
Wuerzburg, Germany
 

Have you figuered it out yet?

Basically you will have to enter your desired input in the php5-install-pre.sh here:

# The domain in which to install the PHP CGI script.
export DOMAIN="your-root-domain.com"

# Where do you want all this stuff built? I'd recommend picking a local filesystem.
# ***Don't pick a directory that already exists!***
SRCDIR=${HOME}/source

# And where should it be installed?
INSTALLDIR=${HOME}/php5

# Set DISTDIR to somewhere persistent, if you plan to muck around with this
# script and run it several times!
DISTDIR=${HOME}/dist

In the php5-install.sh you need to do the same adjustments plus enable the pdo-mysql in PHP Features:

--with-pdo-mysql \

I guess you’ve got the error message because the Dreamhost-wiki was incorrect at the PHP version, but it is correct now. In the php5-install.sh it used to say PHP 5.2.3 instead of 5.2.5

I hope that helped, otherwise report your error here

 
Magento Community Magento Community
Magento Community
Magento Community
 
rareone
Jr. Member
 
Total Posts:  2
Joined:  2008-04-05
 

Well, i have done that, but i now i get this http://www.fuhyoo.com/magento/report/?id=120810290966.18&s;=default

There has been an error processing your request.
Invalid attribute requested: name

hmm, what should i do next?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gabrusch
Member
 
Avatar
Total Posts:  44
Joined:  2008-03-26
Wuerzburg, Germany
 

Actually I think this is not related to the PHP problem or the NO input file specified problem. Never seen this error again.

Try searching the forum is all I can help you with, sorry.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kavi
Jr. Member
 
Total Posts:  3
Joined:  2008-05-09
 

Hi guys,
This is Kavi. I m getting some error in my browser while installing the Magento-1.0.19870. It says “No input file specified”. I hosted in Godaddy and check the PHP version, it is PHP Version 5.2.5 and also enable the Read, Write and Execute permission for Media, Var, and app as per the installation guide. But again i m facing the same issue.

Please any one help me out.

Thanks
Kavi

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

Please see the following thread:

http://www.magentocommerce.com/boards/viewthread/6554/

Crucial - 18 April 2008 11:05 PM

That’s a GoDaddy issue. You’ll want to edit the .htaccess file and add this to top:

Options -MultiViews

If that doesn’t work, add this to your php.ini file:

cgi.fix_pathinfo 1

And if that doesn’t work, rename your php.ini file to php5.ini.

The last one seems to be what fixes it for most people, so try that first.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kavi
Jr. Member
 
Total Posts:  3
Joined:  2008-05-09
 

Hi Crucial,
Greetings !  As per your guidance i got the solution from the “ No input file specified “ error. But As of now i m getting another problem. After completed the Database information, i have seen the following error:

Error in file: “/home/content/s/u/r/sureshdreamz/html/magento/app/code/core/Mage/SalesRule/sql/salesrule_setup/mysql4-install-0.7.0.php” - SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘salesrule’ already exists
Trace:
#0 /home/content/s/u/r/sureshdreamz/html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(278): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /home/content/s/u/r/sureshdreamz/html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(158): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’install’, ‘’, ‘0.7.6’)
#2 /home/content/s/u/r/sureshdreamz/html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(144): Mage_Core_Model_Resource_Setup->_installResourceDb(’0.7.6’)
#3 /home/content/s/u/r/sureshdreamz/html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(111): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/content/s/u/r/sureshdreamz/html/magento/app/code/core/Mage/Core/Model/Config.php(195): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/content/s/u/r/sureshdreamz/html/magento/app/code/core/Mage/Core/Model/App.php(208): Mage_Core_Model_Config->init(Array)
#6 /home/content/s/u/r/sureshdreamz/html/magento/app/Mage.php(357): Mage_Core_Model_App->init(’’, ‘store’, Array)
#7 /home/content/s/u/r/sureshdreamz/html/magento/app/Mage.php(375): Mage::app(’’, ‘store’, Array)
#8 /home/content/s/u/r/sureshdreamz/html/magento/index.php(35): Mage::run()
#9 {main}

Can you help me ?
Eventhough i comment the “ADD UNIQUE `UNQ_CATEGORY_PRODUCT` (`category_id`, `product_id`);” in the mysql4-upgrade-0.7.33-0.7.34.php as per the form. But again i m getting the same error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
benfaust
Jr. Member
 
Total Posts:  8
Joined:  2008-02-08
 

Thank you, thank you, thank you! I’ve been banging my head against the wall (not literally) trying to get Magento to install on a Godaddy hosting account. The cgi.fix_pathinfo = 1 in php5.info did the trick.

 
Magento Community Magento Community
Magento Community
Magento Community
 
benfaust
Jr. Member
 
Total Posts:  8
Joined:  2008-02-08
 

Sheesh… Now I’m getting the “Table ‘salesrule’ already exists” error kavi mentioned too. Anyone know the fix for this? By the way, my client is hosting on Godaddy as well. That seems to be our common denominator. Should I just recommend he finds a real web host?

 
Magento Community Magento Community
Magento Community
Magento Community
 
leaf
Jr. Member
 
Total Posts:  1
Joined:  2008-05-26
 

Hi, i had a big problem of installation. i use godaddy.com host, and put the magento files in the root/magento. when i visit this directory, the page go to “magento/index.php/install/”, and the page just display “No input file specified. “. Could any one help me with this. Thanks
The attachments are the pics of the directories of my host.

 
Magento Community Magento Community
Magento Community
Magento Community
 
priyapriya
Jr. Member
 
Total Posts:  16
Joined:  2009-03-06
 

No Input File Specified
I am getting this error while trying to run http://mysite.com/index.php
my .htaccess files is like as

Options -MultiViews
<IfModule mod_php5.c>
php_flag magic_quotes_gpc off
php_flag short_open_tag on
</IfModule>

Action php5-cgi /cgi-bin/php5-cgi
AddHandler php5-cgi .php

DirectoryIndex index.php

RewriteEngine on

#RewriteBase /

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule .* index.php

I have also renamed php.ini as php5.ini.

I am still getting the error “no input file specified”

Please guide me how to correct this error.

Thanks in advance.

Priya

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fedir
Jr. Member
 
Total Posts:  2
Joined:  2010-10-18
 

Just to tell you, what in my case it was a permission issue. The same error on php-cgi. I had to rename the owner and group to Apache user of the vhost folder recursively.
Kind off :

chown -R apacheuser:apachegroup ./

It worked after for me. You should be root or sudoer to run such command.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2