Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 5 of 5
Image Upload HTTP error second post
 
RobertC
Jr. Member
 
Total Posts:  7
Joined:  2010-05-13
 

I also found you can password protect web directories in the ISP’s control panel.  In GoDaddy this is in their Hosting Control Panel > Content > File Manager > choose a folder > Permissions (icon) etc. .  When protecting the folders in my site, it made the image upload fail as described.  Clearing the protection allowed uploads to work again.  GoDaddy has it’s own help topic on how to password protect folders for more info.

Hope this helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
doughboy
Member
 
Total Posts:  55
Joined:  2010-03-29
 
nasha - 23 April 2010 06:02 AM

Hi
I solved this by installing ‘no-flash-uploader’ extension.

Thanks for this tip!!  this solved my problem.  I have installed several modules this past weekend on 1.4.1.0 and I could no longer upload images??  I changed to the no-flash-uploader and problem solved.

 
Magento Community Magento Community
Magento Community
Magento Community
 
responder
Jr. Member
 
Total Posts:  1
Joined:  2009-11-25
 
Ravikumar N B - 16 March 2009 10:02 PM

I’m running in my local PC and i didn’t configured mod_security with my apache.

I didnt find any SecRule(SecRule HTTP_User-Agent “^Shockwave Flash” ) in my.htacces and httpd.conf file.

I’m on a MAC and used all browsers with Flash 9 and 10. I think this problem is mainly concerning those that are with a shared cPanel hosting company. I’m with eUKhost in the UK and contacted them to make the above change [to mod_security] but they instead ended up fixing the problem another way [apparently, there was a problem with the PHP settings]. The following was added but contact your host and they will fix the issue:

magic_quotes_gpc = off
flag session.auto_start = off
zlib.output_compression = on
suhosin.session.cryptua = off
zend.ze1_compatibility_mode = off
extension=mcrypt.so
extension=pdo.so
extension=pdo_mysql.so
short_open_tag = on
memory_limit = 32M

 
Magento Community Magento Community
Magento Community
Magento Community
 
alfin
Jr. Member
 
Total Posts:  12
Joined:  2008-11-15
 

PROBLEM SOLVED

I was contact my hosting, n why the image doesn’t load after upload file succed, the unswer is:
please comment(#) file .htaccess in folder “media” Options All -Indexes dan Options -ExecCGI as like this:

Options All -Indexes 
Options 
-ExecCGI
to
#Options All -Indexes 
#Options -ExecCGI

Becouse some hosting restricted the “Options” setting for security reason.

And notice if someone have problem cannot upload the image products, the solution is please add a line in php.ini, like this:

suhosin.session.cryptua off

I’m using magento 1.4.1.1, maybe other version applied too.. smile
If it still doesn’t work, please contact your hosting for more information.

wish usefull, thanks
-alfin-

 
Magento Community Magento Community
Magento Community
Magento Community
 
Esger
Jr. Member
 
Total Posts:  1
Joined:  2010-11-16
 

Here’s a solution that worked for me: http://www.shanestillwell.com/tags/magento
The whole directory in which I have Magento installed was password-protected for ‘under construction’ reasons.
Removing the protection did the trick smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
nimonogi
Member
 
Total Posts:  38
Joined:  2008-11-08
 
alfin - 05 August 2010 04:00 PM

PROBLEM SOLVED

I was contact my hosting, n why the image doesn’t load after upload file succed, the unswer is:
please comment(#) file .htaccess in folder “media” Options All -Indexes dan Options -ExecCGI as like this:

Options All -Indexes 
Options 
-ExecCGI
to
#Options All -Indexes 
#Options -ExecCGI

Becouse some hosting restricted the “Options” setting for security reason.

And notice if someone have problem cannot upload the image products, the solution is please add a line in php.ini, like this:

suhosin.session.cryptua off

I’m using magento 1.4.1.1, maybe other version applied too.. smile
If it still doesn’t work, please contact your hosting for more information.

wish usefull, thanks
-alfin-

This may also work just by commenting out #Options -ExecCGI

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 5 of 5