Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Image Upload HTTP error second post
 
Ravikumar N B
Sr. Member
 
Avatar
Total Posts:  213
Joined:  2009-01-12
 

I didnt find any SecRule(SecRule HTTP_User-Agent “^Shockwave Flash” ) in my.htacces and httpd.conf file.
mod_security use any other files.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mattiasmac
Jr. Member
 
Total Posts:  21
Joined:  2008-04-22
 

I have a dedicated server and I use WHM. I logged in to WHM and the very bottom of the link on the left is Mod Security. Click on it and it shows the Mod Security log. Click the edit button. On the edit Mod Security is where I found the line to comment out. Sorry I don’t know any other way to find that file.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ravikumar N B
Sr. Member
 
Avatar
Total Posts:  213
Joined:  2009-01-12
 

Anybody have some other solution for LAMP setup!!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
quanza
Sr. Member
 
Avatar
Total Posts:  97
Joined:  2008-12-02
Tokyo, Japan
 

People, if you’re using .htaccess/.htpasswd files to protect your site, you need to allow POST calls to go through; they’re being blocked b/c the AJAX call doesn’t know to use your cookie.

Just use the LimitExcept directive:

AuthUserFile <path to your .htpasswd>
AuthType Basic
AuthName 
"Some site name"

<LimitExcept POST>
    Require 
valid-user
</LimitExcept>

That should do it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ravikumar N B
Sr. Member
 
Avatar
Total Posts:  213
Joined:  2009-01-12
 

I’m not using .htpasswd file.

You gave the details of enable the authentication.
So this is not impact anything in image upload.

anything else !!!?

 
Magento Community Magento Community
Magento Community
Magento Community
 
taikahn
Member
 
Total Posts:  35
Joined:  2008-04-07
 
Ravikumar N B - 01 March 2009 07:42 PM

I’m not using .htpasswd file.

You gave the details of enable the authentication.
So this is not impact anything in image upload.

anything else !!!?

Actually his fix works perfectly— *** for anyone using a .htaccess file ***

The reason the flash “9” hack works is that it does not support the security protocols properly. And same with “ISP’s awesome” tech support that modded a security feature in the server instead of figuring out the simple passthrough htaccess tags needed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Typeface
Jr. Member
 
Total Posts:  2
Joined:  2009-03-09
 
mattiasmac - 09 February 2009 08:10 PM

OK. I figured it out. Go into the mod_security configurations and comment this line #SecRule HTTP_User-Agent “^Shockwave Flash”
It should work after that.

Thanks, i contacted our hosting company and they commented out this line

#SecRule HTTP_User-Agent “^Shockwave Flash”

in the

mod_security configurations

and now our products have images smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ravikumar N B
Sr. Member
 
Avatar
Total Posts:  213
Joined:  2009-01-12
 

!**!BUMP!**!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ravikumar N B
Sr. Member
 
Avatar
Total Posts:  213
Joined:  2009-01-12
 

I’m running in my local PC and i didn’t configured mod_security with my apache.

I didnt find any SecRule(SecRule HTTP_User-Agent “^Shockwave Flash” ) in my.htacces and httpd.conf file.

 
Magento Community Magento Community
Magento Community
Magento Community
 
CordiS
Jr. Member
 
Total Posts:  3
Joined:  2008-10-31
 

the same problem on Firefox 3.0.7 on Linux

 
Magento Community Magento Community
Magento Community
Magento Community
 
yinzer
Jr. Member
 
Total Posts:  1
Joined:  2009-05-07
 

I was able to fix this error by adding the following to my .htaccess file (all one line):

SetEnvIfNoCase Content-Type "^multipart/form-data;" "MODSEC_NOPOSTBUFFERING=Do not buffer file uploads"
 
Magento Community Magento Community
Magento Community
Magento Community
 
Smurf
Jr. Member
 
Total Posts:  2
Joined:  2008-09-20
 

Nothing that all this work for me!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
mccarrd4
Jr. Member
 
Total Posts:  26
Joined:  2009-06-14
Ireland
 

I was able to solve this problem. I checked my phpinfo() and saw that PHP was not running as an Apache module but as a CGI script instead. Meaning that some of the code needed in the .htaccess file will not work. I posted the solution here - http://www.magentocommerce.com/boards/viewthread/45534/#t147491.

Thanks
Darren

 
Magento Community Magento Community
Magento Community
Magento Community
 
phpkiller
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2009-07-09
Paris
 

Hi, everyone

I have the same problem with firefox3
but it works with IE8

I use local machine windows.

I tried all the solution proposed, it doesn’t work in firefox3

any other solution ??

 
Magento Community Magento Community
Magento Community
Magento Community
 
phpkiller
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2009-07-09
Paris
 

It’s strange, in firefox3 it works now. I don’t know why ?
but it’s ok. tks

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top