Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 5
Image Upload HTTP error second post
 
Georges@Bitbol
Sr. Member
 
Avatar
Total Posts:  104
Joined:  2008-08-07
Paris, France
 

What’s the f… with image uploading ? ^^

I had flash 10 and had to downgrade to 9.
Now I have http errors like all of you.
No special security in apache and I am working on mac. The issue is for my customers. If I had to tell them to work on IE and PC. Hum…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Georges@Bitbol
Sr. Member
 
Avatar
Total Posts:  104
Joined:  2008-08-07
Paris, France
 

Same issue on PC with IE ont three different server.
Anyone has a list of possible stuff making this upload not working.

Flex and javascript are nice but why is there not any classic form solution. What a shame on such a good platform. But is is just a litlle threat

 
Magento Community Magento Community
Magento Community
Magento Community
 
patrickm
Jr. Member
 
Total Posts:  2
Joined:  2008-09-02
 

I was able to resolve this using the htaccess / mod_security found on the first page of this thread.

My situation was just slightly different, so I’ll describe it here in case it helps someone else.

I am not running Magento directly from the webroot, but instead from a subfolder (ex: www.domain.com/store). I have a htaccess at the webroot which allows Magento to appear as though it were running right out of the webroot (so www.domain.com returns the same thing as though the user had typed in www.domain.com/store).

Now, for how this relates to the upload issue: I had to add

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

to my htaccess at the webroot, even though Magento is only present in the /store/ folder. Not sure if this is the ideal fix, but uploading is working once more now that this is in place.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hellodon
Jr. Member
 
Total Posts:  1
Joined:  2008-11-21
 

Hey guys,

I’m still having this problem. I am VERY new to all of this. I edited my htaccess file adding the 2 lines that you guys said to add (which were oddly enough, already there in a different spot) and that didnt do the trick. I tried deleting the htaccess file and that didnt work. So I’m not really sure if I’m following…

Can someone explain to me the proper way to fix this? I tried both safari and firefox (I’m on a mac) and it gets the error both times.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jonw101
Member
 
Total Posts:  73
Joined:  2008-11-14
 

I added
<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

to my .htaccess in the web root.... no difference.  Any other suggestions.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jonw101
Member
 
Total Posts:  73
Joined:  2008-11-14
 

Just to follow up, I called my hosting company and they were able to successfully add an image. I tried on IE7 w/ vista and FF with a mac and neither worked, but they got it to work and cant recommend anything… any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Coralie
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2008-07-25
Paris
 

I had the same problem on PC, MAC, with IE, FF… I solved the problem by cleaning cache before uploading images. I overloaded the Gallery controller (Mage/Adminhtml/controllers/Catalog/Product/GalleryController.php) and the upload action :

public function uploadAction() {
        Mage
::app()->cleanCache();
        
parent::uploadAction();
}

I hope it will help…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ravikumar N B
Sr. Member
 
Avatar
Total Posts:  213
Joined:  2009-01-12
 

Having the same problem.
Uploading with Firefox gives me the Upload HTTP Error, but with Inter Explorer it works just fine.

So It’s not the permissions. But, I chmod the folder 755 then 777 and it doesnt work.
in my .htaccess already set
<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

any solution???????? question

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ravikumar N B
Sr. Member
 
Avatar
Total Posts:  213
Joined:  2009-01-12
 

I try with latest magento 1.2.0.3.
If I try in Firefox, I got Upload HTTP Error, but it is working fine in IE6.
In demo setup i can upload the product image through Firefox 3.0.5 itself.

I gave 777 permission to entire magento folder.

How do i fix this problem???

Thanks in advance…

 
Magento Community Magento Community
Magento Community
Magento Community
 
zvezda
Jr. Member
 
Total Posts:  14
Joined:  2007-09-20
 

I have the same problem.
Uploading with Firefox gives me the Upload HTTP Error, but with Inter Explorer it works just fine.
no solution with permissions
any new idea

thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
mattiasmac
Jr. Member
 
Total Posts:  21
Joined:  2008-04-22
 

Anyone figure this out. I am having the same problem. I have tried all of the above suggestions with no success. Thanks to the one who figures this one out.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mattiasmac
Jr. Member
 
Total Posts:  21
Joined:  2008-04-22
 

OK. I figured it out. Go into the mod_security configurations and comment this line #SecRule HTTP_User-Agent “^Shockwave Flash”
It should work after that.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ravikumar N B
Sr. Member
 
Avatar
Total Posts:  213
Joined:  2009-01-12
 

In magento/.htaccess file i have only following lines

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

I cant found any SecRule in my .htaccess/httpd.conf files.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ravikumar N B
Sr. Member
 
Avatar
Total Posts:  213
Joined:  2009-01-12
 

dont anybody know?

can anybody help?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
mattiasmac
Jr. Member
 
Total Posts:  21
Joined:  2008-04-22
 

Yes I figured it out. Please read my post 2 above this.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 5