Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 5
Image Upload HTTP error second post
 
iamko2008
Jr. Member
 
Total Posts:  17
Joined:  2008-03-25
 

Hey to all!

How is everything going today? Thankful to be hit with the new shopping cart magento of course, I had saw that a previous user had this same problem but I’m not sure if they found a safe solution for it, one user had replied back to something about the MOD_SEC but i figured that was a unsafe thing to modify and leave open for hackings anyway, i want to know if anyone has a solution to this problem that im sure others are having as well. When ever i try to upload a product image in the catalog i get this HTTP error which is attached. Please help me out thanks again for your time!

Image Attachments
error.gif
 
Magento Community Magento Community
Magento Community
Magento Community
 
iamko2008
Jr. Member
 
Total Posts:  17
Joined:  2008-03-25
 

anyone???

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ross
Guru
 
Avatar
Total Posts:  336
Joined:  2007-08-31
Scarborough, North Yorkshire, UK
 

mod_security is an optional Apache module, that most people don’t have anyway.  I think it will be fine to turn it off without being a security problem.

Also, some people have had client side problems (try updating Flash to the latest version, or testing on a different PC), and other people only have problems if they use SSL in the back-end.

Since there are a few situations that cause problems, you will first need to determine which one is causing a problem for you, only then can you find a solution.

Also remember, this is working fine for many people, so it’s not completely broken.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Nathan Roberts
Jr. Member
 
Avatar
Total Posts:  3
Joined:  2008-05-20
Washington, IL
 

Hey guys,

I had this same problem with Firefox and Safari on a Mac (Upload HTTP Error). I successfully uploaded images using a PC.

I noticed that my .htaccess file didn’t copy from my desktop to my web server. I copied the default .htaccess file from my Magento download to my web server, and image uploading works fine now.

Hope this helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Unixversal
Sr. Member
 
Avatar
Total Posts:  80
Joined:  2008-04-23
Cologne, Germany
 

I have the same problem.

Running Mac OSX Leopard version gets me HTTP Errors.
As sugested before I updated my flash version to 9,0,124,0.

I tried with: Opera - newest Version 9
Safari - patched and updated
Firefox 3 - updated

none of these seem to work on a Mac.
Booting my virtual XP environment I could upload via Internet Explorer 7 (for testing purpose only! wink ).

Is there any workaround to be able to use the mac? I really don’t want to transfer the images to XP to be able to do the image step in Adminpannel.

Any ideas? Thank you in advance

-- i am not running in ssl mode!

 
Magento Community Magento Community
Magento Community
Magento Community
 
thetoine
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2008-06-04
Montreal, Canada
 

I have the same issue only when I set a user/password on my domain with an .htaccess

Try upgrading to Flash Player 10 beta maybe ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Unixversal
Sr. Member
 
Avatar
Total Posts:  80
Joined:  2008-04-23
Cologne, Germany
 

alright you found the reason. Deleting the .htaccess protection (which is used to deny access for crawlers and search engines) I am able to upload images using Mac.

Thx for the hint.

Cheers.

 
Magento Community Magento Community
Magento Community
Magento Community
 
emorillo
Jr. Member
 
Total Posts:  4
Joined:  2008-06-10
 

The last post is right about removing that security, but for dummies you need to be more explicit. I actually don’t even know if both lines should be there but I added them to the .htaccess file on the directory where I have magento stored.

SecFilterEngine Off
SecFilterScanPOST Off

Those lines did the job and now I’m able to upload images.

Any feedback?

 
Magento Community Magento Community
Magento Community
Magento Community
 
scree
Sr. Member
 
Avatar
Total Posts:  137
Joined:  2008-07-14
Linz
 

must be a server setting. i moved all the code + database to my second server and it worked out of the box

 
Magento Community Magento Community
Magento Community
Magento Community
 
scree
Sr. Member
 
Avatar
Total Posts:  137
Joined:  2008-07-14
Linz
 

oh, much better than this! today, i work at home instead of the office and today there is no problem with any image upload in the shop. maybe some firewall is blocking http requests or similar.

 
Magento Community Magento Community
Magento Community
Magento Community
 
scree
Sr. Member
 
Avatar
Total Posts:  137
Joined:  2008-07-14
Linz
 

path to tmp directory was set to a directory without write permissons. now it works.

 
Magento Community Magento Community
Magento Community
Magento Community
 
meeeearcus
Member
 
Total Posts:  57
Joined:  2008-07-01
 
Unixversal - 09 July 2008 02:09 PM

alright you found the reason. Deleting the .htaccess protection (which is used to deny access for crawlers and search engines) I am able to upload images using Mac.
Cheers.

Wow, that is strange, I wonder why that is so? I just produced the exact same results by removing the “htaccess” directory protection. Sounds like it may be worth implementing a non-flash workaround uploader until this can be fixed.

This is also a really horrible snag for developers like me who use a Mac as their main machine. The trade off is having to turn off directory protection when I want to upload images. Now explaining that to clients is a whole other story.

That aside, Magento is a breath of fresh air!

 
Magento Community Magento Community
Magento Community
Magento Community
 
greatboatgear
Jr. Member
 
Total Posts:  3
Joined:  2008-09-11
 

Well, I have read on the posts and I still have a problem.
My application ver 1.1.4 runs perfectly on my home server. I copied it to my hosting location where it runs fine apart from uploading images.

The permissions are the same for the application directory and below on both my server and the hosting server.

I have tried with firefox and IE 6 on a XP pro machine. Same results, works fine on my server but not on the hosting server.

The .htaccess files are the same.

So I am sure that it is a server issue.

Anyone have an idea where to look?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
widgetuk
Jr. Member
 
Total Posts:  20
Joined:  2008-10-09
 

I’m having the same problem guys…

I’m using Windows Vista. I’ve tried in Firefox2 and EI7. Can’t upload product images. My install is on linux/apache and using clean installation out of the box 1.1.6 magento. I’ve removed my .htaccess. 

Interestingly I dont have a problem with the image upload on the official magento demo store (demo.magentocommerce.com). works perfectly… as such it must be a server issue in my case for sure.

Anyone have any clues on this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
widgetuk
Jr. Member
 
Total Posts:  20
Joined:  2008-10-09
 

Looking at another thread, some people were suggesting that the following was required in the htaccess “SecFilterEngine Off"… so I’ve checked my .htaccess file, and it appears this is already added in the section..

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

 
Magento Community Magento Community
Magento Community
Magento Community
 
greatboatgear
Jr. Member
 
Total Posts:  3
Joined:  2008-09-11
 

Well I solved my problem by working closely with my hosting company Linksky. It was a server issue.

What was extremely frustrating was that on my own server there was no problem, but on a fresh server at Linksky I had the problem.

The support guy at Linksky got rid of the http error via a mod security setting, but I still had a problem in that the upload would not work. It said completed but never completed. The support guy persevered and after about 2 days said that

“As it turned out I belive we needed to implement a number of suhosin adjustments with this sever which does indeed help some of the more advanced applications to access more memory.”

I believe suhosin is used to add protection to PHP.

I am extremely lucky that I used Linksky, although they had not hosted a Magento app before, they added PDO and solved this obscure problem.

These days getting someone knowledgeable to work with you is really rare.

So, from what I can see, permissions can cause the problem as well as particular browsers and apache settings. We can now add suhosin to the list.

Beats me why they had to use a compiled flash thing. Sure caused and is causing lots of us big problems. Catalog images uploaded fine.

Davar meod mitumtam

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 5