Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Fontis reCaptcha installs to wrong dir
 
Avi999
Jr. Member
 
Total Posts:  23
Joined:  2009-05-21
 

1. my Magento is installed at /var/www/vhosts/site2/html/store
it was moved from main site dir /var/www/html/ long ago.

Our sites are on a VPS server with dedicatd IP.

2. all seems to work fine, frontend and admin works OK
3. I can upgrade installed components through magento connect

Now, when I try to install Fontis reCaptcha through magento connect , installation goes ok but
I get nothing in config->system->admin so I can’t configure reCaptcha

OK, I’ve found that after installation, a Magento directory was created in /var/www/html which is the main
directory at my server and NOT in /var/www/vhosts/site2/html/store where magento is installed !
This new directory consists some Fontis files and more.
I tried to copy the files to the directory where Magento reside and got nada.

How do I fix this ?
How do I force Fontis to install to the correct directory ?

in .htaccess store path is set as
RewriteBase /store/

any help will be appreciated
A

 
Magento Community Magento Community
Magento Community
Magento Community
 
Avi999
Jr. Member
 
Total Posts:  23
Joined:  2009-05-21
 

Problem SOLVED

it was my installation and not reCaptcha !
My Magento was moved from another directory and unfortunately Magento does not handle
this issue very well, I was left with some wrong paths that made this to happen.
After manually altering all the paths to the new location and rebuilding the downloader,
I was managed to install reCaptcha and all seems to be OK.
Sorry for the trouble and I hope others with same problem will benefit from this thread.
A.

 
Magento Community Magento Community
Magento Community
Magento Community
 
erictr1ck
Member
 
Total Posts:  56
Joined:  2009-02-12
 

i am having the same problem. would you mind telling where exactly you altered the paths? were there references in the db? in a config file? thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top