Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Infinate redirects when installing .9
 
GregC
Sr. Member
 
Avatar
Total Posts:  76
Joined:  2007-11-23
A^2, MI
 

Hi all,
Just got a new server set up (CentOS, Apache 2, PHP 5.2).  I’ve got all the right pieces in place, but, am having problems kicking off the install wizard.
I keep getting the dreaded :

the server is redirecting the request for this address in a way that will never complete

I’ve checked the permissions and they are all correct.  Is there someway to debug this issue?

Thanks,
Greg

 
Magento Community Magento Community
Magento Community
Magento Community
 
GregC
Sr. Member
 
Avatar
Total Posts:  76
Joined:  2007-11-23
A^2, MI
 

hummmm… if I run /install.php directly then I get the following error -

Warningpreg_match() [function.preg-match]Internal pcre_fullinfo() error -3 in /magento/beta09/lib/Zend/Cache/Backend/File.php on line 126
[0] in preg_match
("~^[\w]+$~""mage"in /magento/beta09/lib/Zend/Cache/Backend/File.php on line 126
[1] in Zend_Cache_Backend_File
->__construct(Array[4]in /magento/beta09/lib/Zend/Cache.php on line 124
[2] in Zend_Cache
::factory("Core""File"Array[3]Array[4]in /magento/beta09/app/code/core/Mage/Core/Model/App.php on line 800
[3] in Mage_Core_Model_App
->getCache() in /magento/beta09/app/code/core/Mage/Core/Model/App.php on line 817
[4] in Mage_Core_Model_App
->loadCache("use_cache"in /magento/beta09/app/code/core/Mage/Core/Model/App.php on line 885
[5] in Mage_Core_Model_App
->useCache("config"in /magento/beta09/app/code/core/Mage/Core/Model/Config.php on line 189
[6] in Mage_Core_Model_Config
->init(NULLin /magento/beta09/app/code/core/Mage/Core/Model/App.php on line 205
[7] in Mage_Core_Model_App
->init("default""store"NULLin /magento/beta09/app/Mage.php on line 399
[8] in Mage
::app("default"in /magento/beta09/install.php on line 118

exception 
'Zend_Cache_Exception' with message 'Invalid file_name_prefix : must use only [a-zA-A0-9_]' in /magento/beta09/lib/Zend/Cache.php:141
Stack trace
:
#0 /magento/beta09/lib/Zend/Cache/Backend/File.php(127): Zend_Cache::throwException('Invalid file_na...')
#1 /magento/beta09/lib/Zend/Cache.php(124): Zend_Cache_Backend_File->__construct(Array)
#2 /magento/beta09/app/code/core/Mage/Core/Model/App.php(800): Zend_Cache::factory('Core', 'File', Array, Array)
#3 /magento/beta09/app/code/core/Mage/Core/Model/App.php(817): Mage_Core_Model_App->getCache()
#4 /magento/beta09/app/code/core/Mage/Core/Model/App.php(885): Mage_Core_Model_App->loadCache('use_cache')
#5 /magento/beta09/app/code/core/Mage/Core/Model/Config.php(189): Mage_Core_Model_App->useCache('config')
#6 /magento/beta09/app/code/core/Mage/Core/Model/App.php(205): Mage_Core_Model_Config->init(NULL)
#7 /magento/beta09/app/Mage.php(399): Mage_Core_Model_App->init('default', 'store', NULL)
#8 /magento/beta09/install.php(118): Mage::app('default')
#9 {main}

NoticeUndefined variableapp in /magento/beta09/install.php on line 137

Any ideas?

Greg

 
Magento Community Magento Community
Magento Community
Magento Community
 
Draku
Jr. Member
 
Total Posts:  2
Joined:  2008-03-20
 

Same problem :|

 
Magento Community Magento Community
Magento Community
Magento Community
 
petertufan
Sr. Member
 
Avatar
Total Posts:  93
Joined:  2007-08-31
Ashburn, VA
 

Guys .. as I have responded to quite some other people asking the same question ... so far the best installations are done from either the downloaded ZIP file or directly from the SVN - REMEMBER TO BACKUP ALL YOUR CHANGES PRIOR FIRST!!!

Thanks,

Peter Tufan
http://www.asktp.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
Draku
Jr. Member
 
Total Posts:  2
Joined:  2008-03-20
 

Did you think the files magicly apear on the server prior to instalation ?

P.S. In romanian we use the word “sunt” instead of “sint” for over a decade.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Airforce111
Sr. Member
 
Avatar
Total Posts:  100
Joined:  2008-01-31
 
Draku - 26 March 2008 11:42 PM

Did you think the files magicly apear on the server prior to instalation ?

I think what petertufan is trying to get at is, alot of the installation problems can be resolved by downloading/using one of the full install packages and by double checking whether ALL the files have been unpacked properly and is accounted for. Also, you want to check the .htaccess and rewrite rules to ensure they aren’t redirecting to a place that can be redriected over again (hence an infinite loop).

We do not work for magento and is not obliged to help anyone. What we are trying to do is to try and help if we can, volunteerily. It may not be perfect but at least it gives you a place to start. Would you rather we all just not post anything?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top