Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Only The first Page Shows In the FrontEnd - Every other is 404 Error
 
roco
Sr. Member
 
Total Posts:  191
Joined:  2008-03-18
 

I have tried to avoid posting this and have read every forum/group/screencast information I could find but I have not been able to solve what is probably a very basic problem.

http://74.54.207.2/~rconley/magento

--All links on this page and the search are dead?  My Admin works perfect though and I have been able to add a product, assign it a category, install google checkout, import and export items, etc etc.  Just no front end. :(

It seems like a “local root” or “path” issue.

Could someone please point me in the right direction?

Thanks, Rob

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

You have a problem with mode rewrite on your server.
Try to disable it in the admin
You can see that URL with index.php is working http://gator401.hostgator.com/~rconley/magento/index.php/customer/account/login/

 
Magento Community Magento Community
Magento Community
Magento Community
 
roco
Sr. Member
 
Total Posts:  191
Joined:  2008-03-18
 

Hi Lior - Thanks for the quick response and I am glad that there is an easy solution. 

Is this setting in the Admin of my Apache Webserver/PHP5/or Magento?  Could you be a little more specific as to how I might do this? - Thanks Rob

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

Check with your hosting if Apache rewrite can be activated on your server
If not, go to Admin>System> Configuration
In the left Column under General section Web > Search Engines Optimization select NO

 
Magento Community Magento Community
Magento Community
Magento Community
 
roco
Sr. Member
 
Total Posts:  191
Joined:  2008-03-18
 

Ok - Getting warmer

I got this info from HostGator:

Hello,
You must create this file in your ‘public_html’ directory.
If you have any further questions, concerns, or comments, please don’t hesitate to let us know.

can you point me to it in my directory?
Customer Reply
2:55 PM | Mar 25, 2008

Hi Zach - Where is this .htaccess file?
Customer Reply
2:47 PM | Mar 25, 2008

Hi Zach - Where is this .htaccess file?

On Tue, Mar 25, 2008 at 2:34 PM, wrote:
> Hello,
mod_rewrite is compiled in Apache core, and is available for use. You can activate it by putting the line into .htaccess file:
>
RewriteEngine On
>
If you have any further questions, concerns, or comments, please don’t hesitate to let us know.
>

> Level I System Administrator
> HostGator LLC
>
Did you know that you can find answers to the most common issues in our forums? Visit http://forums.hostgator.com/ and give it a try!
>
> Your rating will determine what I get paid. Please rate this response at the url below:
> https://tickets.hostgator.com/rateticket/6653050/412

>

Employee Reply
2:34 PM | Mar 25, 2008

Hello,

mod_rewrite is compiled in Apache core, and is available for use. You can activate it by putting the line into .htaccess file:

RewriteEngine On

------------------------------

So I made the modification to the .htaccess file (which was blank) in the public html dir, and things seem to be working better, but I still get 404 errors when going to logout and my account.  Any ideas?

http://www.eexpeditors.com/magento/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tonyboy
Jr. Member
 
Total Posts:  6
Joined:  2008-03-29
 

I post here because I had the same problem as you.
I have found a solution that works fine for me.
Go to your .htaccess file and find these lines :

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

And replace it with :

############################################
## you can put here your magento root folder
## path relative to web root

    RewriteBase /magento/

With the correct folder of course.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bleevo
Jr. Member
 
Total Posts:  1
Joined:  2008-04-05
 

Thanks this fixed my problem also needed to uncomment the RewriteBase

 
Magento Community Magento Community
Magento Community
Magento Community
 
mozo
Jr. Member
 
Total Posts:  2
Joined:  2008-04-20
 

I am getting the same problem, I disabled rewriting, now I have the problem with the footer links only.
UPDATE: it’s fixed now, I think it might’ve been the cache.

 
Magento Community Magento Community
Magento Community
Magento Community
 
zolute
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2012-10-28
 
Lior - 25 March 2008 07:55 AM

Check with your hosting if Apache rewrite can be activated on your server
If not, go to Admin>System> Configuration
In the left Column under General section Web > Search Engines Optimization select NO

Thanks a ton. Did the trick.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top