Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Site Always Redirects to Cart (after a new shipping method was added)
 
baralmahesh
Jr. Member
 
Total Posts:  2
Joined:  2009-07-07
 

I tried to add a new shipping method using this wiki. It showed up in the backend okay but didnt come up in the front end. I tried the solutions mentioned in there as well but no luck. Finally, I was frustrated and removed all the files that I had created. Now my site redirects back to the ‘/cart’ page everytime I try to click ‘continue’ after entering shipping address.

The server log shows

Directory index forbidden by rule: /home/mysite/mysite.com/html/report/, referer: https://www.mysite.com/checkout/onepage

There’s nothing on the var/log files. But I managed to find this error though on the var/report/ directory for every try I made to checkout.

a:2:{i:0;s:234:"Warning: include(Standard.php) [<a href=’function.include’>function.include</a>]: failed to open stream: No such file or directory in /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Core/functions.php on line 73";i:1;s:2775:"#0 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Core/functions.php(73): mageCoreErrorHandler(2, ‘include(Standar...’, ‘/chroot/home/my...’, 73, Array)
#1 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Core/functions.php(73): __autoload()
#2 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Core/Model/Config.php(788): __autoload(’Standard’)
#3 /chroot/home/mysite/mysite.com/html/app/Mage.php(317): Mage_Core_Model_Config->getModelInstance(’Standard’)
#4 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Shipping/Model/Shipping.php(179): Mage::getModel(’Standard’, Array)
#5 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Shipping/Model/Shipping.php(127): Mage_Shipping_Model_Shipping->getCarrierByCode(’Standard’)
#6 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Shipping/Model/Shipping.php(107): Mage_Shipping_Model_Shipping->collectCarrierRates(’Standard’, ‘1’)
#7 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Sales/Model/Quote/Address.php(528): Mage_Shipping_Model_Shipping->collectRates(’Standard’, Object(Mage_Shipping_Model_Rate_Request))
#8 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Sales/Model/Quote/Address/Total/Shipping.php(142): Mage_Sales_Model_Quote_Address->collectShippingRates(Object(Mage_Shipping_Model_Rate_Request))
#9 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Sales/Model/Quote/Address.php(582): Mage_Sales_Model_Quote_Address_Total_Shipping->collect()
#10 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Sales/Model/Quote.php(887): Mage_Sales_Model_Quote_Address->collectTotals(Object(Mage_Sales_Model_Quote_Address))
#11 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Checkout/Model/Cart.php(337): Mage_Sales_Model_Quote->collectTotals()
#12 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Checkout/controllers/CartController.php(110): Mage_Checkout_Model_Cart->save()
#13 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Core/Controller/Varien/Action.php(367): Mage_Checkout_CartController->indexAction()
#14 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(163): Mage_Core_Controller_Varien_Action->dispatch()
#15 /chroot/home/mysite/mysite.com/html/app/code/core/Mage/Core/Controller/Varien/Front.php(158): Mage_Core_Controller_Varien_Router_Standard->match(’index’)
#16 /chroot/home/mysite/mysite.com/html/app/Mage.php(457): Mage_Core_Controller_Varien_Front->dispatch(Object(Mage_Core_Controller_Request_Http))
#17 /chroot/home/mysite/mysite.com/html/index.php(52): Mage::run()
#18 {main}”;}

I have refreshed cache, even disabled all of them but it looks like it is looking for Standard.php (as shown on the report log below) which may have been one of the files/names that I created while trying to create that shipping method. From where is it trying to include that file??Any Ideas???

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top