Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

проблема с флешом в браузерах. 
 
Deus
Sr. Member
 
Avatar
Total Posts:  122
Joined:  2009-04-16
Russia. Moscow
 

В общем люди добрые такая проблема. Нарисовал, как говорится ролик во флеше. Вместо одного из статичных банеров. Прописал код в странице, закинул swf фал в мультимедию и вот какая собственно проблема. В опере всё работает на ура, в эксплорере ролик не грузится (пустой блок), хотя если просто загрузить swf ролик с компа через эксплорер то он пашет, а в мозиле так его вообще нет. Знающие и умеющие, подскажите пожалуйста в чем может быть косяк. Повторюсь, что в опере то всё работает. АД!

 
Magento Community Magento Community
Magento Community
Magento Community
 
ogonkov
Guru
 
Total Posts:  582
Joined:  2009-03-25
Moscow, Russia
 

В IE вроде как-то через JS он подключался, там стоит какая-то защита, вроде

 
Magento Community Magento Community
Magento Community
Magento Community
 
Deus
Sr. Member
 
Avatar
Total Posts:  122
Joined:  2009-04-16
Russia. Moscow
 

Спасибо за отклик но............  А где рыть то? Ведь сам ролик в IE работает. И про защиту если можно по подробнее (она в движке или браузерах?). Если это конечно возможно. Почему тогда работает в опере?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ogonkov
Guru
 
Total Posts:  582
Joined:  2009-03-25
Moscow, Russia
 

Потому что только в IE защита, погуглите ie flash embed

Вот ваша проблема, скорей всего
http://www.kirupa.com/developer/flash8/flash_fix.htm

 
Magento Community Magento Community
Magento Community
Magento Community
 
Deus
Sr. Member
 
Avatar
Total Posts:  122
Joined:  2009-04-16
Russia. Moscow
 

Спасибо за совет. В общем, конечно интересное решение, но полазив по форумам, на английском нашел решение. Всё заработало во всех браузерах. Однако теперь новая проблема. Сам флеш распологается вместо одного из банеров на главной, под навигацией. Так вот собственно в чем проблема. Под уровни меню теперь почему то выводятся под флешом (то есть флеш их закрывает). Подскажите пожалуйста в чем может быть проблема?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Deus
Sr. Member
 
Avatar
Total Posts:  122
Joined:  2009-04-16
Russia. Moscow
 

Всё. Наконец заработало!!!! Проблемка была в коде самого флеша. Всем спасибо!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top