Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Weird error iconv_substr
 
enyceexdanny
Member
 
Total Posts:  34
Joined:  2009-05-05
 

Hey guys.. I’m not sure if it’s alright to post an issue on a separate thread, but it seems logical to me…
anyways, I’m getting this error. Usually when I click “view order”.

=============================================================

Notice: iconv_substr() [function.iconv-substr]: Detected an illegal character in input string in C:\xampp\htdocs\vivari\app\code\core\Mage\Core\Helper\String.php on line 97

=============================================================

Any idea what it can be?
I searched a bit on this, and it seems to be related to the encoding.. But I have no clue where to actually start touching.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rainbow Forest
Jr. Member
 
Avatar
Total Posts:  23
Joined:  2009-04-29
Belgrade, Serbia
 

Like you said, it’s probably due to the unsupported charset.  I would assume the page contains some strings that iconv cannot convert so it’s not showing the page. Maybe you should start from there ... I can’t really give you any specific suggestion since i don’t have all the info.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top