Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Version 0.9.17740 with APC - Javascript issues
 
srinigenie
Guru
 
Avatar
Total Posts:  539
Joined:  2008-02-04
 

Hi all,

I recently installed the latest BETA version of magento and was surprised to see a lot of javascript errors pop up on my page(particularly backend I am nto able to do anything). I checked the settings and then found that turning off APC - Alternative PHP Cache seemed to do the trick.

Does this mean the latest BETA is not compatible with APC? I didnt face this issue with the previous version.

 
Magento Community Magento Community
Magento Community
Magento Community
 
YoavKutner
Guru
 
Avatar
Total Posts:  491
Joined:  2007-08-08
 

The latest version is compatible with APC. in fact demo.magentocommerce.com is running with APC.

did you install a clean install or upgraded an old one.

Thanks

yoav

 
Magento Community Magento Community
Magento Community
Magento Community
 
srinigenie
Guru
 
Avatar
Total Posts:  539
Joined:  2008-02-04
 

I tried an upgrade an it failed ...so deleted and did a fresh install. Ensured that the APC is cleared of its cache, ensured that the Magento cache is cleared. Still face this issue :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
i960
Guru
 
Avatar
Total Posts:  633
Joined:  2007-10-01
Bakersfield, CA
 

I had issues as well, and I am using APC.  However, I don’t know if APC is causing any problems.  I had problems where replacing Head.php with a version posted by Moshe seemed to do the trick, and then this morning I was getting nothing but this when accessing Admin:

“SYNTAX: proxy.php/x.js?f=dir1/file1.js,dir2/file2.js”

I had made no changes since it last worked, and turning on and off APC did nothing.  Finally I just scrapped everything and started over.  This time I used the installer method instead of downloading the full package, and I have not had any issues whatsoever.  I didn’t even need the patched Head.php.  I’m wondering if there was a difference between the download version and the installer version.  Either way, I am now running 0.9.17740 with APC turned on without any issues.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Actually the issue is not related to APC.
Please check another thread for solution with javascripts.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top