Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Install Problems Link to .htaccess file ‘redirect’?? 
 
ants
Jr. Member
 
Total Posts:  3
Joined:  2008-03-22
 

Hi,

I’ve attempted to install magneto on my hosting account. I’ve followed the instruction given on this site and check with my hosting provider too.

I downloaded the current version of php5-cgi from the website
I uploaded the file to the cgi-bin folder (http://magneto.anthonybeckett.com/cgi-bin/)
I set file permissions to 755 for both the file and the cgi-bin folder

I still get the following error…

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

--------------------------------------------------------------------------------

Apache/1.3.41 Server at magneto.anthonybeckett.com Port 80

I’ve checked the file location is correct.

I asked my hosting provider to confirm that I had the correct system parameters…

Operating System: Linux
Web Server: Apache with CGI support
FileInfo override control via .htaccess files
A user-writable cgi-bin directory
FTP access to your web root and cgi-bin directories

But my host replied saying that I have an error in my .htaccess file - the cryptic response said it was to do with a redirect. I’m not too hot on .htaccess files but as far as I can tell there are no redirects in there. Can anyone see something wrong with this file…

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

    Action php5-cgi /cgi-bin/php5-cgi
    AddHandler php5
-cgi .php
#    php_flag cgi.fix_pathinfo on

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php

############################################
## default index file 

    
DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

    
php_value memory_limit 32M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

</IfModule>

<
IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter
    
SetOutputFilter DEFLATE

    
# Netscape 4.x has some problems...
    
BrowserMatch ^Mozilla/4 gzip-only-text/html

    
# Netscape 4.06-4.08 have some more problems
    
BrowserMatch ^Mozilla/4\.0[678] no-gzip

    
# MSIE masquerades as Netscape, but it is fine
    
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    
# Don't compress images
    
SetEnvIfNoCase Request_URI \
    \
.(?:gif|jpe?g|png)$ no-gzip dont-vary

    
# Make sure proxies don't deliver the wrong content
    
Header append Vary User-Agent env=!dont-vary

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    
AddDefaultCharset Off
    
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    
ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    
Order allow,deny
    Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none

Thanks

Ants

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top