Magento Forum

Error in file: “…/app/code/core/Mage/Catalog/sql/catalog_setup/mysql4-upgrade-0.7.66-0.7.67.php” - Wrong attribute group ID
 
benxico
Member
 
Total Posts:  53
Joined:  2008-09-25
 

Hello,

I’m trying to upgrade on a test server of one of our magento.
Interface_Frontend_Default_Modern 1.3.1.1 (stable) -> 1.3.2.2 (stable) (640kB)
Mage_Core_Modules 1.3.1 (stable) -> 1.3.2.2 (stable) (1588kB)

and I get this :

Error in file: “/var/www/html/m/magento/magento01/app/code/core/Mage/Catalog/sql/catalog_setup/mysql4-upgrade-0.7.66-0.7.67.php” - Wrong attribute group ID
Trace:
#0 /var/www/html/m/magento/magento01/app/code/core/Mage/Core/Model/Resource/Setup.php(292): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /var/www/html/m/magento/magento01/app/code/core/Mage/Core/Model/Resource/Setup.php(179): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’upgrade’, ‘0.7.66’, ‘0.7.69’)
#2 /var/www/html/m/magento/magento01/app/code/core/Mage/Core/Model/Resource/Setup.php(146): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(’0.7.66’, ‘0.7.69’)
#3 /var/www/html/m/magento/magento01/app/code/core/Mage/Core/Model/Resource/Setup.php(121): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /var/www/html/m/magento/magento01/app/code/core/Mage/Core/Model/Config.php(263): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /var/www/html/m/magento/magento01/app/code/core/Mage/Core/Model/App.php(263): Mage_Core_Model_Config->init(Array)
#6 /var/www/html/m/magento/magento01/app/Mage.php(434): Mage_Core_Model_App->init(’’, ‘store’, Array)
#7 /var/www/html/m/magento/magento01/app/Mage.php(455): Mage::app(’’, ‘store’, Array)
#8 /var/www/html/m/magento/magento01/index.php(59): Mage::run()
#9 {main}

If any body have an idea, for the moment we can’t find from where is the problem :(

Bests Regards,

Vincent

 
Magento Community Magento Community
Magento Community
Magento Community
 
w4yward
Member
 
Total Posts:  35
Joined:  2008-10-08
 

Did you ever find a solution for this? The same issue just came up on my site, on the latest upgrade.

 
Magento Community Magento Community
Magento Community
Magento Community
 
benxico
Member
 
Total Posts:  53
Joined:  2008-09-25
 

Hello,

we have found an issue this week smile

For us it was just because we have made a test with a new attribute set than we didn’t finish.

So this new attribute set called “test” was empty, we have just created the set and we did not continue the test and created an attribut in this set.

For the upgrade, we get the error wrong attribute id, because there is no attribute so the upgrade script can’t find the attribute he want to change.

To resolve the problem we have juste delete the attribute set in the magento admin :
Catalog -> Attribute -> Manage Attribute Sets

Hope it could help someone smile

Bests Regards,

Benxico

PS : sorry for my bad english wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
ecctao
Jr. Member
 
Total Posts:  1
Joined:  2009-08-22
 

I found this error smile, it’s becouse of xampp?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Shimi
Jr. Member
 
Total Posts:  22
Joined:  2007-12-04
 

Same issue when trying to install v1.3.2.4

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top