Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Erro na instalação, mcrypt, curl e pear
 
Johnny Thug-N-Harmony
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2008-03-19
são paulo
 

Gente eu tento instalar o Magento e aparece o seguinte erro

no assistente de instalação, primeito aparece que copiou tudo de boa.

depois de clik em ok
erro:
PHP Extension “mcrypt” must be loaded
PHP Extension “curl” must be loaded

se tentar denovo aparece esse erro:
---------------------------------------

Setting preferred state to: beta

config-set succeeded

Downloading and installing Magento, please wait…

Ignoring installed package pear/PEAR
Ignoring installed package mage-core/Mage_Pear_Helpers
Ignoring installed package mage-core/Lib_ZF
mage-core/Lib_Varien requires PHP extension “curl”
mage-core/Lib_Varien requires PHP extension “mcrypt”
mage-core/Mage_All requires package “mage-core/Lib_Varien” (version >= 0.9.17740, version <= 0.9.17740)
mage-core/Mage_All requires PHP extension “curl”
mage-core/Mage_All requires PHP extension “mcrypt”
mage-core/Interface_Frontend_Default requires package “mage-core/Mage_All” (version >= 0.9.17740, version <= 0.9.17740)
mage-core/Interface_Adminhtml_Default requires package “mage-core/Mage_All” (version >= 0.9.17740, version <= 0.9.17740)
mage-core/Interface_Install_Default requires package “mage-core/Mage_All” (version >= 0.9.17740, version <= 0.9.17740)
Array
(
[data] => Array
(
[0] => Array
(
[0] => No valid packages found
)

)

[headline] => Install Errors
)

PEAR ERROR: install failed

---------------------------------------------------------------------

Gente, me ajuda por favor…
gostaria de testar, gostei bastante do demo, dever ser melhor ainda completo

gente, desde já agradeço a alma que puder me ajudar. abraço

 
Magento Community Magento Community
Magento Community
Magento Community
 
licentia
Sr. Member
 
Avatar
Total Posts:  78
Joined:  2007-08-31
Portugal
 

Boas,

Esse erro acontece porque não tens as livrarias curl e mcrypt instaladas, e o Magento necessita delas

Vê mais informações de como instalar no site do PHP

curl:
http://pt2.php.net/manual/pt_BR/ref.curl.php

Mcrypt
http://pt2.php.net/manual/pt_BR/ref.mcrypt.php

Estás em Windows ou Linux?

EDITADO.

Criei um sistema que verifica se o servidor é compatível com o Magento. Pode descarregá-lo em anexo neste tópico

http://www.magentocommerce.com/boards/viewthread/4749/

Saudações

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bernardo
Jr. Member
 
Total Posts:  5
Joined:  2008-05-21
Rio de Janeiro
 

Sobre o mcrypt, você baixa o libmcrypt.dll aqui http://files.edin.dk/php/win32/mcrypt/ e coloca na pasta raiz do php e em c:\windows\system32

 
Magento Community Magento Community
Magento Community
Magento Community
 
rcflash
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2008-12-12
 

Boa Tarde,

Galea estou com este mesmo problema baixei a versão mais recente o magneto e não consigo instalar

esta dando este erro

*
o PHP Extension “mcrypt” must be loaded
o PHP Extension “curl” must be loaded

Sou novato em php, se alguem tiver um passo a passo para ensinar a fazer estes códiogos eu agradeço.

vlw


[RESOLVIDO] no Wampserver ja tem uma opção que habilita estes arquivos, para quem quizer ai vai
na bandeja clique com o bt do mouse em cima do icone do wampserver.
Escolha o opção PHP.
Ecsolha PHP Extensions.
Dai é só procurar na lista que aparece os arquivos.

Obrigado

 
Magento Community Magento Community
Magento Community
Magento Community
 
amartinez
Guru
 
Avatar
Total Posts:  347
Joined:  2008-11-14
Spain
 

Me pasó algo similar en UBUNTU, que resolví así:

apt-get --reinstall install php5-mcrypt
/etc/init.d/apache2 restart

un saludo!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Adriano Aguiar
Moderator
 
Avatar
Total Posts:  343
Joined:  2008-08-26
Sao Paulo
 

Olá Pessoal, se vocês estiverem com alguma dúvida sobre as configurações e compatibilidade de servidor quanto ao suporte para magento, acessem:

System Requeriments :

http://www.magentocommerce.com/system-requirements

File Magento-check.php

http://www.magentocommerce.com/knowledge-base/entry/how-do-i-know-if-my-server-is-compatible-with-magento Publiquei no servidor e vejam as pendências.

Valeu!

 
Magento Community Magento Community
Magento Community
Magento Community
 
rodrigowsi
Jr. Member
 
Total Posts:  1
Joined:  2012-09-19
 
amartinez - 31 March 2009 07:57 AM

Me pasó algo similar en UBUNTU, que resolví así:

apt-get --reinstall install php5-mcrypt
/etc/init.d/apache2 restart

un saludo!

Perfeito, com esses dois comandos consegui resolver meu problema no linux

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top